Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

This happened to me as well.

I tried reloading and it still wasn't working. I also tried installing OpenSUSE Tumbleweed and ran into the exact same problem. I reloaded Fedora once I realized the problem was in my own $HOME.

The problem seems the be a rouge extension. I would clear your extensions -- specifically, the one that seems to be causing the issue is "Workspaces to Dock".

What I would do is hit ctrl+alt+f3 and then cd ~/.local/share/gnome-shell/extensions. Once in ls and then rm -rf the folder containing the "Workspaces to Dock" extension. If it still continues to clear all your extensions. If it still persists, clear all your Gnome settings but this should not be necessary if it is the same issue. Shame because it was my favorite extension. I hope there is a fix soon.

This happened to me as well.

I tried reloading and it still wasn't working. I also tried installing OpenSUSE Tumbleweed and ran into the exact same problem. I reloaded Fedora once I realized the problem was in my own $HOME.

The problem seems the be a rouge extension. I would clear your extensions -- specifically, the one that seems to be causing the issue is "Workspaces to Dock".

What I would do is hit ctrl+alt+f3 and then cd ~/.local/share/gnome-shell/extensions. Once in ls and then rm -rf the folder containing the "Workspaces to Dock" extension. If it still continues to clear all your extensions. If it still persists, clear all your Gnome settings but this should not be necessary if it is the same issue. Shame because it was my favorite extension. I hope there is a fix soon.

UPDATE: The newest version of the extension as it is in GitHub appears to work and does not lock up Gnome Shell.

The author of the extension said that Version 45 should be landing on the Gnome Extension website in the next few days and they have been slow to update the site because there have been a lot of submissions.