Ask Your Question

Revision history [back]

Static address never takes that long. I can tell you, it works just great under Fedora. I guess you have some conflict or hostname problem. Check your hostname first.

This should take only less than second:

# service network restart

Check your /var/log/message log, please paste your ifcfg-eth0 (edit the question and add it there please). Make sure you have at least those options there:

DEVICE=eth0
BOOTPROTO=static
HWADDR=00:30:48:56:XX:XX
IPADDR=10.X.X.X
NETMASK=255.255.255.192
ONBOOT=yes