Ask Your Question
2

how to enable audio in a fresh fedora minimal netinstall?

asked 2017-02-08 21:34:39 -0500

murpholinox peligro gravatar image

I liked i3wm http://i3wm.org/ and decided to make it my default desktop. So I make a minimal netinstall (https://download.fedoraproject.org/pub/fedora/linux/releases/25/Workstation/x8664/iso/Fedora-Workstation-netinst-x8664-25-1.3.iso) chose the software as: minimal setup (first column) and standard packages (2nd column). Fedora started in cli mode. OK. Then I installed VLC, Firefox, Vim and i3 (along with their respective dependencies). Of course I made all the stuff to execute i3 with the command startx ...so i3 works fine. When I go to youtube there is no audio at all. So google says that the most common error is that by default the sound is muted. Ok I go to the terminal and type alsamixer unmute everything and raise the volume to 100% in all the possible columns. Reboot ...nothing yet. Then I try in VLC...and I can hear /usr/share/sounds/alsa/Front_Center.wav depending on the chosen device:

  • HDA Intel HDMI 0 HDMI Audio Output -> No sound
  • HDA Intel HDMI 1 HDMI Audio Output -> No sound
  • HDA Intel HDMI 2 HDMI Audio Output -> No sound
  • HDA Intel PCH ALC233 Analog Default Audio Device -> Sound
  • HDA Intel PCH ALC233 Analog Default Audio Device -> Sound ( Do not know why it is duplicated)
  • HDA Intel PCH ALC233 Analog Front Speakers -> Sound
  • HDA Intel PCH ALC233 Analog 2.1 blahblah -> No sound
  • HDA Intel PCH ALC233 Analog 4.0 blahblah -> Sound
  • HDA Intel PCH ALC233 Analog 4.1 blahblah -> No sound
  • HDA Intel PCH ALC233 Analog 5.0 blahblah -> No sound
  • HDA Intel PCH ALC233 Analog 5.1 blahblah -> Sound
  • HDA Intel PCH ALC233 Analog 7.1 blahblah -> Sound
  • default -> No sound

So it seems to me that the problem is how to tell alsa what device to use but I can't seem to work it out. Any help will be appreciated. ;) Thanks

PS. Even though I am trying i3wm ....I am not really an expert in linux. PS Sorry for the long post :P

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-02-09 11:37:45 -0500

murpholinox peligro gravatar image

Wow.... got the same problem as user kadaver...here The problem gets solved with this line (suggested by user Gusar).

echo "options snd-hda-intel index=1" > /etc/modprobe.d/alsa.conf
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-02-08 21:34:39 -0500

Seen: 531 times

Last updated: Feb 08 '17