Ask Your Question
1

User file access in Fedora 25

asked 2017-02-13 00:53:11 -0500

hend gravatar image

I have been using Ubuntu for the last 5 years and recently decided to try Fedora 25. I have hassles when trying to access files on drives other than my home folder. I have to provide a password to access a different drive, and some times my USB stick mounts as read only. How do I change the configuration to allow access to specific locations outside of my home folder?

I thought it would be in fstab but I don't see details there. Is this a SElinux issue?

edit retag flag offensive close merge delete

Comments

Just to clear up a little confusion on your part, Linux doesn't use drives the way Windows does. Take a look at the Linux Filesystem at Wikipedia to see how this is handled in Linux.

sideburns gravatar imagesideburns ( 2017-02-13 19:45:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-02-13 02:43:33 -0500

shark gravatar image
  1. open gnome-disks.
  2. select the hard disk partition and click on the GEAR button and select EDIT MOUNT OPTIONS.
  3. Turn the AUTOMATIC MOUNT OPTIONS to off.
  4. Make sure MOUNT AT STARTUP and SHOW IN USER INTERFACE are on
  5. Customise other settings like IDENTIFY AS or FILESYSTEM TYPE ( you must know what you are doing as it edits the fstab )
  6. Click ok and reboot This trick works for partitions on the hard drive
edit flag offensive delete link more

Comments

Or, after making the changes, open a terminal and run sudo mount -a to remount all partitions listed in fstab.

sideburns gravatar imagesideburns ( 2017-02-13 19:46:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-02-13 00:53:11 -0500

Seen: 227 times

Last updated: Feb 13 '17