how can i enable my nvidia driver correctly ?

asked 2017-03-07 15:24:08 -0500

berkozel1911 gravatar image

hy fedora users!

i installed latest Fedora to my MSI GP62 6QE (i7-6700 HQ, 8G RAM, NVIDIA GeForce GTX 950m) laptop. I couldn't enter to installition, so i added "nomodeset" to boot config (while press e to open menu) file before start to install.

And, i finalized installition with 800x600 resolution, and restarted my system with Fedora. But i can't find my 1080p resolution on list. There is only 800x600 resolution.

I'm scaring to delete nomodeset from grub config, because i think i won't access to desktop, stuck at black screen with "OK" lines...

edit retag flag offensive close merge delete

Comments

i think my nvidia driver is already enabled, but i just want disable intel graphics, it's correct question.

berkozel1911 gravatar imageberkozel1911 ( 2017-03-07 15:34:33 -0500 )edit

Disableing the intel is probably going to be a bios setting.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-03-07 18:15:36 -0500 )edit

If you need to disable the Intel kernel module you need to add a blacklist.conf file in /etc/modprobe.d/ with a line like blacklist i915

aeperezt gravatar imageaeperezt ( 2017-03-07 18:27:05 -0500 )edit

The first order of business is to find out what graphics card/cards you have. Please post the response to lspci | grep VGA so that we can make sure that you actually have an Intel adapter to disable.

sideburns gravatar imagesideburns ( 2017-03-07 21:32:13 -0500 )edit