Ask Your Question
1

can't enable cups.service to boot

asked 2017-04-02 05:53:57 -0500

kaestchen gravatar image

hi fedoristas,

after a systemupdate my printer was missing. i figured out that after

sudo systemctl start cups.service

my missing printer is back. BUT

sudo systemctl enable cups.service

and the same as root aren't helping. everytime i restart, my printer is gone again and i have to manually start the cups.service.

any ideas or additional information you need?

kernel: 4.10.6-200.fc25.x86_64

edit:

after a restart

systemctl status cups.service

gives me

Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
Active: failed (Result: start-limit-hit) since So 2017-04-02 12:46:00 CEST; 45s ago
Docs: man:cupsd(8)
Process: 1697 ExecStart=/usr/sbin/cupsd -l (code=exited, status=1/FAILURE)
Main PID: 1697 (code=exited, status=1/FAILURE)

systemd[1]: cups.service: Failed with result 'exit-code'.
systemd[1]: Starting CUPS Scheduler...
cupsd[1697]: cupsd: Cannot get a status of /etc/resolv.conf
systemd[1]: cups.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: Failed to start CUPS Scheduler.
systemd[1]: cups.service: Unit entered failed state.
systemd[1]: cups.service: Failed with result 'exit-code'.
systemd[1]: cups.service: Start request repeated too quickly.
systemd[1]: Failed to start CUPS Scheduler.
systemd[1]: cups.service: Failed with result 'start-limit-hit'.
edit retag flag offensive close merge delete

Comments

@kaestchen -> Are there any messages from journalctl? Journal

hhlp gravatar imagehhlp ( 2017-04-02 12:10:03 -0500 )edit

@hhlp - i runned journalctl without any arguments, i got a related(?) error massage:

avahi-daemon[871]: Failed to open /etc/resolv.conf: Invalid argument

kaestchen gravatar imagekaestchen ( 2017-04-02 14:09:25 -0500 )edit

I have the identical issue. Problem started after an upgrade from Fedora 24 to 25. I have since reinstalled cups. Had to reinstall my printers. Problem persists. Waiting for solution.

CAPSLOCKON gravatar imageCAPSLOCKON ( 2017-04-02 19:06:55 -0500 )edit

Not sure if this will help but can you check the SELinux context for you file /etc/resolv.conf do ls -laZ and paste results here, please.

aeperezt gravatar imageaeperezt ( 2017-04-02 22:02:47 -0500 )edit

lrwxrwxrwx. 1 root root systemu:objectr:netconft:s0 35 Apr 2 17:41 resolv.conf -> /var/run/NetworkManager/resolv.conf

CAPSLOCKON gravatar imageCAPSLOCKON ( 2017-04-03 00:02:01 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
0

answered 2017-04-04 02:37:05 -0500

kaestchen gravatar image

In the end i did a clean install to solve the issue.

Before that, i tried to dnf remove cups an put it back in. Didn't work.

And i tried to build cups 2.2.2 and 2.2.3 from source. Doing something like that for the first time i merely hoped for a lucky shot, but i didn't get my braveness rewarded.

edit flag offensive delete link more

Comments

having this same issue, tried various changes to the service file, nothing worked. I booted to 4.9.14 and everything is fine, so the culprit appears to be 4.10 and I wonder what can be done. I can not do a clean install, too many hours invested getting the system working. I may just make an autostart script in my desktop environment to run cups after login.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-04-05 10:56:44 -0500 )edit

Around midnight local time, i received a large number of updates, amongst them was cups, and it is now working again. if you are still having problems, try doing sudo dnf update and see if cups is presented to you also. The version info shows 2.2.0-7 and it works automatically on reboot.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-04-06 08:34:25 -0500 )edit
1

Big thank you to team Fedora / RedHat / and whoever else contributed to fixing the problem.

This is a major reason why I prefer Linux to other O/S's. Issues are dealt with in a very timely manner and there are great support sites like here for assistance.

CAPSLOCKON gravatar imageCAPSLOCKON ( 2017-04-06 22:27:12 -0500 )edit
0

answered 2017-04-03 02:16:10 -0500

sideburns gravatar image

It may be a kludge, but you could create a shell script to start the service, store it as /etc/rc.d/rc.local (You'll need root access to put it there.) and then run the following two commands:

sudo chmod +x /etc/rc.d/rc.local
sudo systemctl enable rc-local.service

This will set it to run at the very end of the boot process, so that if there's a timing issue causing this, the service will be ready to start by the time this runs. BTW, the second command may not be needed, as it's supposed to run at boot if the file exists, but it can't hurt to be sure and only takes a few seconds.

edit flag offensive delete link more

Comments

I tried this earlier but it didn't work. Thanks anyway.

I also modified /lib/systemd/system/cups.service with After=network-online.target Then ran systemctl daemon-reload. Followed with a reboot. Unfortunately, this didn't work either.

CAPSLOCKON gravatar imageCAPSLOCKON ( 2017-04-03 03:56:45 -0500 )edit

It's not working for me and if i want to enable the rc-local.service, i get:

The unit files have no installation config (WantedBy, RequiredBy, Also, Alias
settings in the [Install] section, and DefaultInstance for template units).
This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
.wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
a requirement dependency on it....
kaestchen gravatar imagekaestchen ( 2017-04-03 04:58:51 -0500 )edit

where is the second answer? the counter says "2" but i have only one.

kaestchen gravatar imagekaestchen ( 2017-04-03 07:00:33 -0500 )edit
1

One of the answers was deleted.

CAPSLOCKON gravatar imageCAPSLOCKON ( 2017-04-03 16:40:30 -0500 )edit

deleted answers shouldn't count...

kaestchen gravatar imagekaestchen ( 2017-04-04 02:28:31 -0500 )edit
0

answered 2017-04-03 22:50:54 -0500

owlbrudder gravatar image

On my Fedora 25 x8664 system, I have cups-2.2.0-6.fc25.x8664 and can confirm the bug is still there. In fact, I only encountered this bug report because I was Googling the problem, which only came to my attention on this machine yesterday, Monday Australian time.

It is strange, because I had no problem previously and I have not run a system update since Saturday afternoon Australian time, the latest cups version having been sent to the repository on Friday.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-04-02 05:36:15 -0500

Seen: 1,086 times

Last updated: Apr 04 '17