Ask Your Question
1

Why ifup takes so long to set up a static IP?

asked 2011-11-26 09:28:13 -0500

ztank1013 gravatar image

updated 2011-11-27 08:11:35 -0500

I admit it I switched back to fedora 15 (and now 16) after many years playing Ubuntu. I feel very comfortable with fedora 16 now but only one thing is annoying me: bringing up a network card takes to long!

Is there any geek out there able to tell me why if I run

/etc/sysconfig/network-scripts/ifup eth0

it takes almost 20 seconds to setup a static IP address? I would understand (or at least try to understand) if I was running a DHCP on my router, but I am not!

In any previous Ubuntu version I tested, bringing up a network interface (even a wireless encrypted one) was a matter of few seconds...

edit:

# cat /etc/sysconfig/network-scripts/ifcfg-Wired_connection_1 
TYPE=Ethernet
BOOTPROTO=none
DNS1=8.8.8.8
DNS2=8.8.4.4
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME="Wired connection 1"
UUID=...     <- intentionally removed
ONBOOT=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
HWADDR=...   <- intentionally removed my MAC addr
IPADDR0=...  <- intentionally removed my public IP
PREFIX0=14
GATEWAY0=... <- intentionally removed
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-27 06:06:20 -0500

ZenDark gravatar image

Are you not using NetworkManager to set up your card?

If you are using the old system (/etc/sysconfig/network manual configuration) maybe you has the IPv6 protocol enabled and in dhcp mode...

Also keep in mind that in Fedora 15 "ethX" name was deprecated and that devices are now named differently: eth0 -> p32p1 in my machine

Docs: Fedora 15 ethX

In Fedora 16 ethX are not avaliable

edit flag offensive delete link more
0

answered 2011-11-27 06:18:32 -0500

lzap gravatar image

Static address never takes that long. I can tell you, it works just great under Fedora. I guess you have some conflict or hostname problem. Check your hostname first.

This should take only less than second:

# service network restart

Check your /var/log/message log, please paste your ifcfg-eth0 (edit the question and add it there please). Make sure you have at least those options there:

DEVICE=eth0
BOOTPROTO=static
HWADDR=00:30:48:56:XX:XX
IPADDR=10.X.X.X
NETMASK=255.255.255.192
ONBOOT=yes
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-26 09:28:13 -0500

Seen: 3,019 times

Last updated: Nov 27 '11