Ask Your Question
2

fedora 25 slow boot. LNXVIDEO is taking a long time

asked 2017-04-24 15:33:00 -0500

talalaev.i.a gravatar image

Hi there!

I have terribly slow boot with fedora 25. Here is my systemd-analyze

Startup finished in 2.083s (kernel) + 3min 19.105s (initrd) + 41.187s (userspace) = 4min 2.377s

graphical.target @41.164s
└─multi-user.target @41.164s
  └─libvirtd.service @19.835s +4.209s
    └─remote-fs.target @19.753s
      └─remote-fs-pre.target @19.753s
        └─iscsi-shutdown.service @19.696s
          └─network.target @19.696s
            └─wpa_supplicant.service @21.594s +341ms
              └─dbus.service @12.040s
                └─basic.target @12.018s
                  └─sockets.target @12.018s
                    └─dbus.socket @12.017s
                      └─sysinit.target @11.968s
                        └─systemd-update-utmp.service @11.932s +35ms
                          └─auditd.service @11.380s +536ms
                            └─systemd-tmpfiles-setup.service @11.149s +199ms
                              └─fedora-import-state.service @10.909s +224ms
                                └─local-fs.target @10.896s
                                  └─run-user-42.mount @22.723s
                                    └─local-fs-pre.target @10.050s
                                      └─lvm2-monitor.service @2.477s +5.140s
                                        └─lvm2-lvmetad.service @3.222s
                                          └─lvm2-lvmetad.socket @2.476s
                                            └─-.slice

I have tried to look up the problem in journalctl -b and found out that fedora hangs on several following rows (you could see it spends for about two minutes in waiting for two LNXSYSTM devices):

Apr 25 02:02:49 localhost.localdomain systemd[1]: Reached target Initrd Root Device.
Apr 25 02:03:48 localhost.localdomain systemd-udevd[331]: seq 1198 '/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01' is taking a long time
Apr 25 02:03:48 localhost.localdomain systemd-udevd[331]: seq 1307 '/devices/pci0000:00/0000:00:01.0/0000:01:00.0' is taking a long time
Apr 25 02:03:48 localhost.localdomain systemd-udevd[331]: seq 1268 '/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:2e/LNXVIDEO:00' is taking a lon
Apr 25 02:04:48 localhost.localdomain dracut-initqueue[371]: /bin/dracut-initqueue@28(main): check_finished

Here is my lspci output which tells me that 01 and 00 are Host bridge and my processor

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b4)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)

Im newbie with linux, and I cannot understand

  • what are the devices fedora is waiting ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-01-10 01:44:48 -0500

talalaev.i.a gravatar image

updated 2018-01-10 01:48:56 -0500

After 6 months I resolved that problem,

the issue occurred from ACPI, I didn't realized what happens on low level.

In order to disable ACPI support pass:

acpi=off

in linux kernel boot params. To do this change in:

vim /etc/default/grub

the line:

GRUB_CMDLINE_LINUX="rhgb quiet acpi=off"

And save settings:

grub2-mkconfig -o /boot/grub2/grub.cfg
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-04-24 15:31:29 -0500

Seen: 548 times

Last updated: Jan 10 '18