Ask Your Question
0

Problem about downgrade and wine.

asked 2017-05-04 05:02:29 -0600

eexpss gravatar image
▶ dnf list wine --showduplicates
Last metadata expiration check: 3 days, 1:14:44 ago on Mon May  1 16:42:30 2017.
Available Packages
wine.i686                               1.9.21-1.fc25                              fedora 
wine.x86_64                             1.9.21-1.fc25                              fedora 
wine.i686                               2.4-2.fc25                                 updates
wine.x86_64                             2.4-2.fc25                                 updates

▶ sudo dnf downgrade wine-2.4-2.fc25
Last metadata expiration check: 2:43:58 ago on Thu May  4 15:13:28 2017.
No package wine-2.4-2.fc25 available.
Error: Nothing to do.

▶ sudo dnf install wine 
....
 wine                             x86_64       2.6-1.fc25             updates        56 k
 wine-alsa                        i686         2.6-1.fc25             updates       107 k
 wine-alsa                        x86_64       2.6-1.fc25             updates       110 k
....

2.6 not in the list, why?

But,,,, with wine 2.6, I can not input any key in some(maybe all) games. I had changed many options in winecfg but fail.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-05-04 10:09:41 -0600

florian gravatar image

updated 2017-05-04 10:13:00 -0600

I think wine-2.6 just made it to the repos, your metadata is > 3 days old, and therefor it's not showing up. If you refresh it, 2.6 should appear: dnf list --refresh --showduplicates wine.

Actually your dnf downgrade command uses recent metadata, and that's why wine-2.4 is not found.

If you want wine-2.4 or 2.5 for Fedora 25, you can get it from the build system. Remove your wine 2.6 first, then use dnf to install the rpm from koji

edit flag offensive delete link more

Comments

When i execute dnf list --refresh, 2.4 gone, only 1.9 and 2.6 here now. So dnf update not refresh matadata? For I had do a update at 2017-05-03 16:30.

eexpss gravatar imageeexpss ( 2017-05-04 21:15:11 -0600 )edit

Take a look at the value

metadata_expire=...

in /etc/yum.repos.d/fedora.repo and /etc/yum.repos.d/fedora-updates.repo

florian gravatar imageflorian ( 2017-05-05 01:40:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-04 05:02:29 -0600

Seen: 84 times

Last updated: May 04 '17