Ask Your Question
0

How to install nvidia driver on fedora

asked 2012-10-11 10:02:21 -0500

HerrKlemmy gravatar image

Hey there,

I'm new to Fedora 17, but not new to Linux. But on this distribution I have problems to install the video driver for my Nvidia GeForce 9700M GTS. I visited many forums and did most of their tutorials, but nothing worked. I downloaded the driver as a .run-file and did the following things :

  1. The kernel update.
  2. Switched to antoher terminal with ctrl+alt+f1
  3. Stopped the service lightdm.
  4. Started the .run-file as root.

Unsolved problem : the nouveau kernel driver which should be disabled. After lots of blacklisting in lots of config-files I thought that was it. But after thousands of these minimal changes, the problem still is the same...

I tried also this nice Tutorial (http://www.if-not-true-then-false.com/2012/fedora-17-nvidia-guide), and at least it did something, but after a reboot most times its laggy and sometimes the system crashes.

So please, the nvidia-crash-problems are the reason why i switched from Ubuntu, please, can somebody help me out of this crashing chaos ?

In love, Klemens

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-10-12 16:35:58 -0500

Iki gravatar image

Hi, you should follow the guide in fedoraforum that davidva linked and install the rpmfusion package for the driver. Ask there too if you need extra help (it's very straightforward but it will be good if you make sure you have uninstalled properly the driver from NVIDIA).

edit flag offensive delete link more
0

answered 2013-04-22 08:08:27 -0500

slacker gravatar image

updated 2013-04-22 08:09:27 -0500

This is the solution I used on Fedora 18, not sure if it will work with Fedora 17.

Here is how I installed the drivers provided by NVidia and disable Nouveau. Note, you will have to do this each time the kernel is updated.

1. Boot into fedora 18 with the run level set to 3
2. sudo mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
3. sudo dracut --omit-drivers nouveau /boot/initramfs-$(uname -r).img $(uname -r)
4. Reboot and make sure to boot into runlevel 3
5. nouveau is now disabled
6. Run the NVidia installer
7. Reboot and load normally.
edit flag offensive delete link more

Comments

This will work, but (as you mentioned) you're going to have to do it again each and every time there's a kernel update. The guides listed above (two links, but the instructions are the same) do it in a far more sane manner, so that the drivers get updated together with the kernel.

sideburns gravatar imagesideburns ( 2013-04-22 15:09:01 -0500 )edit

Do not used the nvidia binary. They do a lot of changes to your system that cannot be undone.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-04-25 06:48:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-11 10:02:21 -0500

Seen: 5,429 times

Last updated: Apr 22 '13