Ask Your Question
1

Keyboard and mouse issues after upgrading packages today

asked 2017-05-27 22:29:56 -0500

Nesvik gravatar image

I just updated this morning, and since the update, my keyboard stops working after a few minutes. Its a logitech G15, it stays lit up but the keys stop registering anything. If I unplug it and plug it back in, i get a few more minutes, and then it cuts off again. Mouse doesn't scroll properly. Can anyone help me figure out whats going on?

$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 039: ID 046d:c227 Logitech, Inc. G15 Refresh Keyboard
Bus 001 Device 038: ID 046d:c226 Logitech, Inc. G15 Refresh Keyboard
Bus 001 Device 037: ID 046d:c223 Logitech, Inc. G11/G15 Keyboard / USB Hub
Bus 001 Device 003: ID 046d:c041 Logitech, Inc. G5 Laser Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub`

lsusb still shows it connected UPDATE: I reverted to last Kernel version and the problem persists. Thanks,

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-06-03 06:25:30 -0500

p4kman gravatar image

updated 2017-06-03 14:00:23 -0500

Got the same issue with G15 keyboard, I downgraded the following packages that I believed could be the source of the issue:

libebitdo, libdfu, fwupd, storaged, libstoraged, libinput

run: #sudo dnf downgrade libebitdo libdfu fwupd storaged libstoraged libinput

After reboot It is working it should, so one of those packages induced a bug... need to re-update 1 by 1 to see which is

Edit: After testing individual updates, the bug is caused by fwupd/libdfu that replace libebitdo, as temporary fix you need to downgrade those packages

sudo dnf downgrade fwupd libdfu
edit flag offensive delete link more

Comments

This fixed the problem for me too. Thanks a lot !!

gmahieux gravatar imagegmahieux ( 2017-06-10 15:16:45 -0500 )edit
0

answered 2017-06-01 13:59:11 -0500

Hi,

I have the same problem since the same update with the same keyboard.

Symptoms are quite the same : No problem to log in, the keyboard is active but a few seconds after the session is started it stops working. Unplug and re-plug make it works again without any issue after (even after standby) until next reboot.

I also noticed weird behavior of scroll lock, num lock and caps lock leds : When the keyboard stops working, numlock is automatically switched off and scroll lock is switched on. After unplug/re-plug everything works fine but the leds will stay switched off even if numlock/capslock/scrolllock keys are pressed (however, key presses are correctly taken into account)

I would also be interested in some help to investigate on this problem

Thanks in advance

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-27 22:29:56 -0500

Seen: 1,450 times

Last updated: Jun 03 '17