Ask Your Question
0

Permission denied

asked 2017-06-19 00:12:24 -0500

Hello,

I am trying to extract a theme to the /usr/share/themes folder when every time I try to run the process it prompts me with permission denied". It originally prompted me with a similar message but once I added my user account under the root group using visudo, that switched to "Permission denied".

I am running Fedora 25 workstation, please help.

Thank you!

edit retag flag offensive close merge delete

Comments

Your user shouldn't be part of the root group. If you want to be able to use the sudo command, place your user in the wheel group.

florian gravatar imageflorian ( 2017-06-19 09:07:01 -0500 )edit

I could already use the sudo command. I was trying to right click the file and extract it to /usr/share/themes when my permission got denied.

alecryncavage gravatar imagealecryncavage ( 2017-06-19 09:30:50 -0500 )edit

You can't and shouldn't run any graphical application such as the file manager nautilus as root. And your "simple" user has no write access to /usr/share/themes (and you should not change that) So, everything is just as it should be.

Just extract the archive to a temp folder in your /home directory, then use sudo cp to copy * from that directory to /usr/share/themes.

florian gravatar imageflorian ( 2017-06-19 10:03:24 -0500 )edit

See if this Q/A might be useful for you: https://ask.fedoraproject.org/en/ques...

florian gravatar imageflorian ( 2017-06-19 10:06:18 -0500 )edit

I ran the command and nothing happened. Screenshot

In the Q/A the solution was this "/home/user/.local/share/themes/", I do not have that themes folder inside share.

alecryncavage gravatar imagealecryncavage ( 2017-06-19 10:23:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-19 09:05:25 -0500

florian gravatar image

updated 2017-06-20 15:27:34 -0500

Is that a multi-user system and you want the theme to be available for every user? Only then you need to place it in a "global" folder. (extract it in your home folder and then use sudo cp -r <source> /usr/share/themes to copy it.

If only you want to use the theme or there is only one user, just use the .themes directory in your home folder (~/.themes)

edit flag offensive delete link more

Comments

It is only myself on the system. I cannot find the .themes directory. I went to /home/alecryncavage and couldnt find it.

If you can't tell, I am new to Fedora.

alecryncavage gravatar imagealecryncavage ( 2017-06-19 09:33:30 -0500 )edit

That you don't see it might have causes. Either you don't see it because it a hidden directory (indicated byt the .), so turn visibility for on hidden files and folders (in nautilus CTRL + h), or it simply doesn't exist. Then you have to create it. (mkdir ~/.themes)

florian gravatar imageflorian ( 2017-06-19 10:05:11 -0500 )edit

I found the hidden files, and the .themes directory is not there. Can I create by running that exact command above mkdir ~/.themes?

alecryncavage gravatar imagealecryncavage ( 2017-06-19 10:15:47 -0500 )edit

Yes, mkdir ~/.themes will create it. ~ is a placeholder for /home/alecryncavage. (The home folder of the logged in user.)

You can also use Nautilus or any other file manager to create the directory.

florian gravatar imageflorian ( 2017-06-19 10:38:23 -0500 )edit

Created the directory and extracted the theme to the new .themes. Restarted my machine then opened Tweak Tool. The new theme doesn't show up in the drop down menu.

alecryncavage gravatar imagealecryncavage ( 2017-06-19 10:50:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-06-19 00:12:24 -0500

Seen: 896 times

Last updated: Jun 20 '17