Ask Your Question
1

Unable to update Fedora 25

asked 2017-06-23 11:10:34 -0500

buvaneshkumar gravatar image

I'm using Fedora 25. I am unable to update my Fedora. If I run #dnf update -y, it is throwing following error

Error: Transaction check error: file /usr/lib/libBasicUsageEnvironment.so.1.0.0 from install of live555-2016.10.21-1.fc25.i686 conflicts with file from package libBasicUsageEnvironment1-2016.03.16-1.1.i586

Does anyone know how to fix this conflicts error?

edit retag flag offensive close merge delete

Comments

1

try adding --best and --allowerasing, but do not run the update with the -y and you will see what the proposed changes are, before you do it.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-06-23 13:01:18 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-06-24 00:28:38 -0500

villykruse gravatar image

I would suggest to uninstall libBasicUsageEnvironment1-2016.03.16-1.1.i586 as it apparently provides a file which is also is provides by the package live555 as found on rpmfusion-free. Perhaps your list of repositories includes sites which don't belong on a fedora system. Do provide the output from

dnf repolist
edit flag offensive delete link more
-1

answered 2017-06-23 13:28:18 -0500

ddkroyal001 gravatar image

dnf upgrade --best --allowerasing

edit flag offensive delete link more

Comments

copy my comment to your answer? lame.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-06-23 13:33:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-06-23 11:10:34 -0500

Seen: 294 times

Last updated: Jun 24 '17