Ask Your Question
0

Fedora 25: grub2-efi uses wrong configuration file

asked 2017-07-30 04:23:05 -0500

octied gravatar image

I recently had to upgrade the MBR to GPT on my boot drive and I also installed grub2-efi, since my new mainboard uses EFI. Now I have the problem that grub does not upgrade the list of available kernel images on the boot screen.

When I use

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

the correct list of kernel images is written to the configuration file. But when I boot my PC I get a different (old) list of kernel images, which shows kernel images that are no longer installed.

edit retag flag offensive close merge delete

Comments

what is the output of efibootmgr ?

Rabin gravatar imageRabin ( 2017-07-30 17:41:25 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-07-31 15:46:26 -0500

octied gravatar image

So i found the solution. I only had the line

UUID=... /boot      ext4    defaults        1 2

in /etc/fstab regarding boot, so I had to add

UUID=... /boot/efi  vfat    defaults umask=0077,shortname=winnt 0 2

restart and then regenerate the grub config file

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
edit flag offensive delete link more
0

answered 2017-07-30 17:39:32 -0500

Rabin gravatar image

The GRUB2 wiki page is a good place to start with: https://fedoraproject.org/wiki/GRUB_2

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-30 04:23:05 -0500

Seen: 267 times

Last updated: Jul 31 '17