Extremely slow wired internet on Fedora 17

asked 2013-01-26 22:46:00 -0500

Adora-Vivos gravatar image

updated 2014-09-28 09:07:31 -0500

mether gravatar image

Hello. I am running a Toshiba Satellite L840D, dualbooting Windows 7 and Fedora 17 (XFCE spin).

I have just installed Fedora 17 (never used Linux on this laptop before) and the wired internet runs extremely slowly: the fastest I have ever seen it go is 1 kb/s. On my working connection on Windows, it often nears 1 mb/s. I have tried the default setting of automatically acquiring all info about the connection, copying the addresses from my Windows' 'ipconfig' output to the connection through the Connection Manager, as well as many different DNS servers.

I am on university internet, and attempting 'dhclient' returned that my request was blocked. I was able to ping 127.168.0.1 and my default gateway from Windows, but attempting to ping anything outside of that (I tried 8.8.8.8) just hung indefinitely.

I would try to connect wirelessly, but the network connection manager claims my wifi is disabled through a hardware switch. Which is true, my wifi light is not on, however I could not find any way to turn it on.

Trying to update everything that needed it through yum was a failure, as after half an hour, it had failed to load even half of the first package source. (As I said, top speed was 1 kb/s but was more commonly around 20 b/s) Timeouts were frequent and changing mirrors did nothing for the speed.

If you have an http link to some file I need to install or something, I can download it and install from that, since obviously as it stands installing through yum isn't going to work.

Thanks in advance!!

edit retag flag offensive close merge delete

Comments

I am wondering if you use some special software or configuration to connect from windows. If windows logging to domain? Some automatic proxy configuration? It is not uncommon to see weird access controls in organizations.

Aleksandar Kostadinov gravatar imageAleksandar Kostadinov ( 2013-02-21 03:19:15 -0500 )edit