Ask Your Question
1

Screensaver starts even while I am actively typing in the terminal?

asked 2017-08-06 14:34:22 -0500

dehvokahn gravatar image

Hi Fedora Friends!

Problem:

When I'm using my system, often times I am using the terminal for several hours without touching the mouse.

After the typical "inactivity" time, my screensaver activates, even though I am typing into the terminal.

So the problem is: "Terminal keyboard activity is not recognized by the screensaver as activity".

Expected / Desired outcome:

I would like to update settings appropriately so that when I use the keyboard in a terminal, the screensaver does not1 activate while I am typing.

What I have tried:

So far I have tinkered with the settings and read through the man pages for xscreensaver, and conducted several internet searches. To no avail, or at least, I couldn't find anything that seemed relevant.

My System Details:

Fedora 25, Wayland (I think), and xscreensaver

I can get any additional details needed. Thanks in advance!

edit retag flag offensive close merge delete

Comments

Going to test, to see if cinnamon, with no wayland, has the same problem. I run xscreensaver, from inside of the cinnamon desktop as an additional set of screensavers.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-08-06 15:12:51 -0500 )edit

TESTED: Set xscreensaver to one minute, read man pages in terminal with just keyboard nagivation, no screensaver. Left terminal open, no typing, and at precisely 56 seconds, screensaver started. Press the down arrow key, and screensaver exited and returned to terminal. Terminal was run windowed, not fullscreen. Are you running terminal from the GUI, or using Ctrl-Alt-F2 to get tty terminal?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-08-06 15:27:13 -0500 )edit

cool, thanks @steveebey73742 !

dehvokahn gravatar imagedehvokahn ( 2017-08-06 15:27:45 -0500 )edit

wow fast @steveebey73742 ! I'm running the terminal windowed. I have not tested with other terminal emulators, only "gnome-terminal" (defaulted terminal in fedora 25 activities menu)

dehvokahn gravatar imagedehvokahn ( 2017-08-06 15:31:13 -0500 )edit

cinnamon uses gnome-terminal as well. I run Nvidia proprietary 384.59 and a usb keyboard, that I paid 10.00 for at wal-mart when my logitech died. i have an amd fx 6300, 16gb ram, no power management in use, as I run 24/7 hosting private services for some of my clients.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-08-06 15:40:31 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-08-07 14:20:10 -0500

dehvokahn gravatar image

With the help of @steveebey73742, I've determined the problem is actually gnome.

After installing cinnamon and switching to that desktop environment, the problem indeed goes away, and typing is no longer missed as user activity in any terminal or other applications (so far).

So, to recap:

Problem:

typing in terminals is not recognized as user activity, and the screensaver activates while typing

Root Cause:

gnome seems to have a bug in how it recognizes user activity

Solution:

  • Temporary solution: Replace gnome with a different desktop environment. Cinnamon does not have this problem.
  • Long term solution: Report this as a bug with gnome so that it can be fixed in a later patch/revision.
  • Potential longer term solution: Maybe discover that I like a different desktop environment better. ;-)
edit flag offensive delete link more

Comments

I am glad that my help was useful to you. I enjoy cinnamon, and chose it, because it is the fastest responding desktop, imo.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-08-07 23:06:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-08-06 14:34:22 -0500

Seen: 75 times

Last updated: Aug 07 '17