Ask Your Question
2

Creating a Desktop Shortcut

asked 2017-08-14 11:46:03 -0600

matthall gravatar image

updated 2017-08-14 16:35:34 -0600

hhlp gravatar image

I'm trying to create a short-cut for Wing IDE, a Python IDE I recently installed. I don't want to run it from the terminal. I have the .desktop file created in ~/.local/share/applications/

[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Wing Personal IDE
Comment=Wing Personal IDE for Python
Exec=/usr/local/bin/wing-personal
Icon=/usr/local/lib/wingide-personal6.0/resources/wing-gnome-icon.png
Terminal=false

If I go to the location of this file in my file explorer and attempt to open it by double-clicking the Wing icon, I get an error message that says "There was an error launching the application."

Please help. I have logged out and logged back in again, but still cannot launch the application without manually typing the command into terminal. Thank you.

edit retag flag offensive close merge delete

Comments

I downloaded the rpm packages from https://wingware.com/ and installed it. It showed up in the application menu under Development. And clicking on its entry started it up properly.

villykruse gravatar imagevillykruse ( 2017-08-15 20:03:59 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-08-15 00:35:33 -0600

villykruse gravatar image

If you want to make that ,desktop entry executable you need a #! line as the first linem and also you need to chmod +x the .desktop file.

#!/usr/bin/env xdg-open
[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Wing Personal IDE
Comment=Wing Personal IDE for Python
Exec=/usr/local/bin/wing-personal
Icon=/usr/local/lib/wingide-personal6.0/resources/wing-gnome-icon.png
Terminal=false

The entry should have shown up in the application menu system, at least on xfce it would under the Other submenu, That way you can start this application same way as all the other application you would start from the application menu system.

edit flag offensive delete link more

Comments

Thanks for your suggestion. I've added the line and made the file executable, then I rebooted my system. The issue still persists. I cannot find the application if I click "Activities" and then "Show Applications" from the doc menu. Also, if I navigate to the .desktop file manually and try to open it, I still have the error "There was an error launching your application"

matthall gravatar imagematthall ( 2017-08-15 12:00:19 -0600 )edit
1

Just to make sure; Does it work if you run /usr/local/bin/wing-personal from a shell prompt?

villykruse gravatar imagevillykruse ( 2017-08-15 14:56:38 -0600 )edit

Thank you! I double checked and I left off the 6.0 on wing-personal6.0 in the Exec= line. This is the kind of attention to detail that I just didn't have as a new Fedora user.

matthall gravatar imagematthall ( 2017-08-16 00:00:22 -0600 )edit
0

answered 2017-08-14 14:39:16 -0600

davidva gravatar image

updated 2017-08-14 14:40:06 -0600

Hey! with menulibre you can make a desktop-shortcut easily...

1. su

2. dnf -y install menulibre

Video tutorial here

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-08-14 11:46:03 -0600

Seen: 1,641 times

Last updated: Aug 15 '17