Ask Your Question
2

Fedora 26 issues! Please Help! Can't Update my computer!

asked 2017-09-21 18:01:57 -0500

dmoe gravatar image

updated 2017-09-22 02:00:16 -0500

hedayat gravatar image

Hi I'm having issues with some kind of conflict that I don't know how to fix when I do a software update I get this in my terminal! I have ran the dnf clean packages and tried updating and I still get this message. Thanks DMoe

Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/doc/glibc/NEWS from install of glibc-2.25-10.fc26.i686 conflicts with file from package glibc-2.25-9.fc26.x86_64
  file /usr/share/man/man5/krb5.conf.5.gz from install of krb5-libs-1.15.1-28.fc26.i686 conflicts with file from package krb5-libs-1.15.1-25.fc26.x86_64

Error Summary
-------------
edit retag flag offensive close merge delete

Comments

What is the exact command you are running to do the update?

villykruse gravatar imagevillykruse ( 2017-09-22 01:14:23 -0500 )edit

I had something similar when I was trying to install Steam at one point. Then I did this and it worked. Read it through and try it out

bombandealer gravatar imagebombandealer ( 2017-09-22 19:36:12 -0500 )edit

su -c "yum update"

dmoe gravatar imagedmoe ( 2017-09-24 22:54:30 -0500 )edit

I use su -c "yum update" to update my system or dnf update

dmoe gravatar imagedmoe ( 2017-09-24 22:59:43 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-09-22 02:05:10 -0500

hedayat gravatar image

I guess you have had a broken update process before (e.g. due to power failure or something like that), and you are left with duplicated packages. Run the following command:

rpm -e --nodeps $(dnf -C repoquery --duplicated --latest-limit=-1 -q)

And then try updating again.

edit flag offensive delete link more

Comments

Thank you! It worked!!!!! I am now able to update! Thanks again :)

dmoe gravatar imagedmoe ( 2017-09-24 23:23:42 -0500 )edit

:)You're welcome!

hedayat gravatar imagehedayat ( 2017-09-25 17:02:11 -0500 )edit
0

answered 2017-09-23 00:19:21 -0500

Nicholas gravatar image

updated 2017-09-23 00:30:16 -0500

Firstly, did you install a 32-bit version of glibc?

i686 = 32-bit Intel x86 arch 
x86_64 = 64-bit Intel x86 arch

Remove:

sudo dnf remove krb5-libs-1.15.1-28.fc26.i686

Clean all and show dups:

dnf clean all 

dnf list --showduplicates glibc

Requires Rescue Mode if only 1 glibc version is installed:

rpm -e --nodeps --justdb glibc glibc-common

x86_64: dnf install glibc

Also, try:

DNF History:

sudo dnf clean all && sudo dnf check-update

sudo dnf history

sudo dnf history undo 23 -y
edit flag offensive delete link more

Comments

Hi Nicholas, I have only installed 64 bit intel x86 arch

dmoe gravatar imagedmoe ( 2017-09-24 22:58:41 -0500 )edit

Thank you Nicholas for the help.

dmoe gravatar imagedmoe ( 2017-09-24 23:11:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-21 18:01:57 -0500

Seen: 1,251 times

Last updated: Sep 23 '17