Ask Your Question
0

mount -t cif mount error(112): Host is down

asked 2017-10-13 09:54:39 -0500

stonne gravatar image

updated 2017-10-13 10:00:23 -0500

Hi, I found out after update the system that I cannot mount a NAS as I do daily, (I said after update the system because that is the only change I've done on my fedora25 box, until yesterday everything was going OK.). I usually mount my NAS HD from command line using this line:

$ sudo mount -t cifs //192.168.0.54/share /mnt/share/ -o username=user,uid=value,rw,sec=ntlm

Now, the only output I got is:

$ mount error(112): Host is down 
  Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

As I've just tested:

  • The ip NAS's addres is correct
  • $ ping NAS'ip output it's also OK
  • I even can access my stuff on the NAS trough its ip-webacces page also from tablet or phone,

I would appreciate any clue or help on this.

edit retag flag offensive close merge delete

Comments

Please give us the output of

smbclient -L 192.168.0.54
toddandmargo gravatar imagetoddandmargo ( 2017-10-13 19:12:50 -0500 )edit

Hi @toddandmargo. Sorry setting here do not allowed to answer your question readable. The mark-up <pre><code> here is not working.

stonne gravatar imagestonne ( 2017-10-16 13:41:42 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2017-10-13 19:11:14 -0500

jmt gravatar image

updated 2017-10-13 19:13:42 -0500

mount.cifs changed in the recent update. One change that hit me was:

No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.

For the previous I had to add option vers=1.0 or vers=2.0. Your error message, however, implies some other problem.

Take a look at dmesg on another terminal (dmesg -w) while you try to mount your disk. You will most probably see and error message that explains why your mount now fails.

edit flag offensive delete link more

Comments

Well, I found a temporary (I hope) solution by booting on the second in line kernel, the one I was using before updating the system & it works, Now I can mount my NAS without issues, so the problem is in the last fedora25 kernel version. (¬¬ worried!)

stonne gravatar imagestonne ( 2017-10-14 11:58:12 -0500 )edit

You know that is only a temporary fix. The changes in the kernel that affect mount.cifs will most likely be permanent.

jmt gravatar imagejmt ( 2017-10-15 05:22:27 -0500 )edit

OK, but where (would anyone know to say e.g. where) I might find info about how-to proceed so adapt to my settings...?

stonne gravatar imagestonne ( 2017-10-16 12:53:34 -0500 )edit

Look at mount errors in dmesg

jmt gravatar imagejmt ( 2017-10-21 14:35:59 -0500 )edit

@jmt is there a solution that you can post that allows the user to use the new "more secure dialect?" I am getting the exact same error that the OP. I was able to get it to mount without the Host is down error by adding vers=1.0 (I'm using /etc/fstab). Thanks.

theroark gravatar imagetheroark ( 2017-11-12 16:49:04 -0500 )edit
0

answered 2017-10-16 13:57:16 -0500

stonne gravatar image

Hi @toddandmargo I could not include the info below your comment so here it goes:

$ sudo smbclient -L 192.168.0.54
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.3-31a.osstech]

    Sharename       Type      Comment
    ---------       ----      -------
    info            Disk      LinkStation Utilities
    share           Disk      LinkStation folder
    boooks          Disk      
    homediadocs     Disk      
    sitebk          Disk      
    mediadocs       Disk      
    libros          Disk      
    bittes          Disk      bittorrent
    homme           Disk      puente-aereo
    IPC$            IPC       IPC Service (LinkStation)
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.3-31a.osstech]

    Server               Comment
    ---------            -------
    LS-XL671             LinkStation
    MATTUTI-TOSH         

    Workgroup            Master
    ---------            -------
    WORKGROUP            LS-XL671
edit flag offensive delete link more

Comments

I had the same issue, but with a Buffalo LinkStation that supports only SMB 2.0 and that was disabled. I enabled SMB 2.0 and added vers=2.0 to the fstab entry and all is well.

Given this was an incompatible change, it would have saved me a but of time if the error message in dmesg was output as the mount error message instead of the incorrect "Host is down" error. It wasn't. I could ping it.

fixpertise gravatar imagefixpertise ( 2017-11-24 16:05:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-10-13 09:54:39 -0500

Seen: 3,235 times

Last updated: Oct 16 '17