Ask Your Question
0

Openvas-manager not starting in F26

asked 2017-10-18 08:12:01 -0500

dconti2008 gravatar image

updated 2017-10-19 04:25:02 -0500

I have installed Fedora26 Security Spin and also Fedora 26 XFCE spin and followed the same installation steps as I used to do on Fedora 25 XFCE to install openvas and greenbone security assistant.

However on Fedora 26 after running openvas-check-setup I arrived to the point where I need to start openvar-manager and this is failing

Steps gone through

systemctl restart redis
openvas-check-setup --v9
systemctl restart openvas-scanner
ps -leaf | grep openvas                        ( see NVTs loading )
openvas-check-setup --v9
openvasmd --rebuild                            ( seems nothing is done )
systemctl restart openvas-manager            ( fails to start )
edit retag flag offensive close merge delete

Comments

Fails to start, or just hangs / seems to do nothing? What is the message?

linuxfabrik gravatar imagelinuxfabrik ( 2017-10-18 09:20:04 -0500 )edit

Openvas-manager fails to start. openvasmd --rebuild seems to do nothing as this should rebuild the NVT and take quite some time to finish

dconti2008 gravatar imagedconti2008 ( 2017-10-18 09:57:40 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2017-10-19 01:17:10 -0500

updated 2017-10-19 03:09:06 -0500

Maybe you should try to configure GPG manually, before running openvas-setup - I have in mind that there are some errors in the openvas-setup:

# add more entropy
yum -y install rng-tools
rngd --rng-device /dev/urandom

# create some missing directories
mkdir -p /usr/share/openvas/gsa/locale
mkdir -p /var/lib/openvas/openvasmd/gnupg
mkdir -p /var/lib/openvas/scap-data/private

# fix permissions and run gpg agent
chmod 0700 /var/lib/openvas/openvasmd/gnupg
gpg-agent --homedir=/var/lib/openvas/openvasmd/gnupg --daemon

After that:

openvas-setup

EDIT: after that, if building the database is ok, but for example certificates are missing, try this:

openvas-check-setup
gpg --enable-special-filenames --batch --no-sk-comment --homedir /var/lib/openvas/gnupg --status-fd 17 --no-tty --charset utf8 --enable-progress-filter --gen-key -- -&18
edit flag offensive delete link more
0

answered 2017-10-19 03:50:40 -0500

dconti2008 gravatar image

Thanks for your updates as now it finally works.

Steps done :

dnf -y install gnutls-utils
openvas-manage-certs -a openvasmd          ( to start openvas-manager)
systemctl restart openvas-gsa
openvas-check-setup --v9

seems all ready to run !!!

edit flag offensive delete link more

Comments

Would be nice to upvote the answers that helped you to find the solution.

linuxfabrik gravatar imagelinuxfabrik ( 2017-10-23 08:59:48 -0500 )edit

Dear @dconti2008, your posts would be more appropriate to be posted as 'comments' rather than 'answers'. Also, it'd be great if you Accept @linuxfabrik's answer by clicking on the tick button besides his/her answer.

hedayat gravatar imagehedayat ( 2017-10-26 16:49:00 -0500 )edit

thanks for youe comments. first time using a forum. I have updated the comments in the answer provided above. Maybe all this answer can be deleted now

dconti2008 gravatar imagedconti2008 ( 2017-10-29 00:45:30 -0500 )edit

Thanks :) Welcome to Ask Fedora!

hedayat gravatar imagehedayat ( 2017-10-29 12:48:51 -0500 )edit
0

answered 2017-10-19 02:25:15 -0500

dconti2008 gravatar image

Dear linuxfabrik

Thanks for your answer and in fact it seems to have built the NVT database correctly after creating the directory structure.

Now it seems the openvas-check-setup --v9 requires the Openvas certificate which should be built by 'openvas-manage-certs -a'.

However this command is failing as it requires 'certtool'

Regards

edit flag offensive delete link more

Comments

I edited my answer.

linuxfabrik gravatar imagelinuxfabrik ( 2017-10-19 03:09:43 -0500 )edit

If you just need certtool, you can install it using dnf -y install gnutls-utils.

linuxfabrik gravatar imagelinuxfabrik ( 2017-10-19 03:19:35 -0500 )edit

It'd be great if you update your answer with this suggestion. Thanks! :) (And please let me know if you did it).

hedayat gravatar imagehedayat ( 2017-10-26 16:49:56 -0500 )edit

Thanks for your updates as now it finally works.

Steps done :

dnf -y install gnutls-utils
openvas-manage-certs -a openvasmd          ( to start openvas-manager)
systemctl restart openvas-gsa
openvas-check-setup --v9

seems all ready to run !!!

dconti2008 gravatar imagedconti2008 ( 2017-10-29 00:43:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-10-18 08:12:01 -0500

Seen: 1,059 times

Last updated: Oct 19 '17