Ask Your Question
0

Can't get docker.service to run in Fedora 26 Workstation

asked 2017-10-19 09:16:03 -0500

Dave J gravatar image

I am trying to run Docker on Fedora 26 Workstation with these commands:

sudo dnf install docker
sudo systemctl start docker

Docker fails on start up. The error messages from journalctl are listed below. I tried again with firewalld turned off. It failed; those error messages are also listed below. I removed the time stamps from the error messages to make them more readable.

The two cases have this error in common:

Error initializing network controller: list bridge addresses failed: no available network

I can run virtual machines with Virtual Machine Manager, so I know the virtual bridge works in some cases.

My question is: Are there additional steps needed to get Docker to run on Fedora 26 Workstation?

Thanks


sudo systemctl start docker
journalctl  -xe


audit: NETFILTER_CFG table=nat family=2 entries=59
audit: NETFILTER_CFG table=filter family=2 entries=103
audit: NETFILTER_CFG table=filter family=2 entries=103
audit: NETFILTER_CFG table=filter family=2 entries=101
audit: NETFILTER_CFG table=filter family=2 entries=100
firewalld[14568]: WARNING: COMMAND_FAILED: '/usr/sbin/iptables -w2 -t nat -n -L DOCKER' 
failed:
audit: NETFILTER_CFG table=nat family=2 entries=57
firewalld[14568]: WARNING: COMMAND_FAILED: '/usr/sbin/iptables -w2 -t filter -n -L DOCKER' failed:
audit: NETFILTER_CFG table=filter family=2 entries=98
firewalld[14568]: WARNING: COMMAND_FAILED: '/usr/sbin/iptables -w2 -t filter -n -L DOCKER-ISOLATION' failed:
audit: NETFILTER_CFG table=filter family=2 entries=100
firewalld[14568]: WARNING: COMMAND_FAILED: '/usr/sbin/iptables -w2 -t filter -C DOCKER-ISOLATION -j RETURN' failed:
audit: NETFILTER_CFG table=filter family=2 entries=102
dockerd-current[1820]: Error starting daemon: Error initializing network controller: list bridge addresses failed: no available network
audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 
subj=system_u:system_r:init_t:s0 msg='unit=docker comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
systemd[1]: docker.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: Failed to start Docker Application Container Engine.


---------------------------------------------------------------------
sudo systemctl stop firewalld.service
sudo systemctl start docker
journalctl  -xe

kernel: nf_conntrack version 0.5.0 (65536 buckets, 262144 max)
dockerd-current[2434]: time="2017-09-19T09:08:53.751645532-04:00" level=info msg="Firewalld running: false"
audit: NETFILTER_CFG table=nat family=2 entries=0
audit: NETFILTER_CFG table=nat family=2 entries=5
audit: NETFILTER_CFG table=filter family=2 entries=4
audit: NETFILTER_CFG table=filter family=2 entries=6
audit: NETFILTER_CFG table=filter family=2 entries=8
dockerd-current[2434]: Error starting daemon: Error initializing network controller: list bridge addresses failed: no available network
systemd[1]: docker.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: Failed to start Docker Application Container Engine.
edit retag flag offensive close merge delete

Comments

Are you using something else for the network besides NetworkManager? Also, is your system completely up to date (including selinux policies)? It could be that SELinux is blocking those firewall commands at the beginning of the log, have you tried disabling it temporarily?

masteroman gravatar imagemasteroman ( 2017-10-19 15:10:07 -0500 )edit

Thanks for your reply. I turned off SELinux with setenforce 0 but it made no difference. I have not made any changes to the network configuration. (I assume NetworkManager is the default in Fedora). I noticed these messages that I did not see before (they appear whether or not SELinux is running):

dockerd-current[18178]: time="2017..." level=warning msg="Your kernel does not support cgroup rt period"
dockerd-current[18178]: time="2017-..." level=warning msg="Your kernel does not support cgroup rt runtime"
Dave J gravatar imageDave J ( 2017-10-20 07:04:39 -0500 )edit
1

This is all rather weird. More so as I'm using docker fine with default setup on Fedora 26. Are you perhaps connected to some VPN or anything that may have its fingers in network related configuration?

masteroman gravatar imagemasteroman ( 2017-10-20 11:39:56 -0500 )edit

Also, I assume you have rebooted the system in the meantime?

masteroman gravatar imagemasteroman ( 2017-10-20 11:40:34 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-10-21 10:50:13 -0500

Dave J gravatar image

Problem solved. It was the VPN.

I rebooted the system and started the docker.service without running the VPN software (I am using AirVPN). The docker.service started up and I was able to run hello-world.

I can now start and stop the docker.service whether or not the VPN is running. I don't believe rebooting alone fixed the problem because I am sure I tried rebooting in the course of my troubleshooting. I will be sure to verify this when I upgrade to Fedora 27.

Thanks masteroman, I never would have suspected the VPN.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-10-19 09:16:03 -0500

Seen: 330 times

Last updated: Oct 19 '17