Ask Your Question
0

Can't add a partition to fstab

asked 2017-10-20 10:22:34 -0500

RushKing gravatar image

I am running fedora on an SSD. What I like to do is use the SSD for my root and home directories, and have my swap partition (sdb1) on a mechanical hard drive plus an additional Ext4 partition (sdb2) that I would like to mount automatically. I would normally use symbolic links for my Music and Downloads directories that point to folders on the additional Ext4 partition (sdb2) .

Every time I add this partition to the fstab, I end up in emergency mode. It says it can't assess the root console and that it's locked. I remove it from the fstab and the PC boots up fine. Does this have to do with me not adding a root account on installation?

This is how I set it up my fstab.

#
# /etc/fstab
# Created by anaconda on Thu Oct 19 17:55:23 2017
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=4861c764-4099-4374-b95d-345e1635ebdc /                       ext4    noatime,discard,defaults        1 1
UUID=CBE0-68BA          /boot/efi               vfat    umask=0077,shortname=winnt 0 2
UUID=7fbc8504-c557-4551-9f08-bab06c3d2d15 /home                   ext4    noatime,discard,defaults        1 2
UUID=3dd4235b-9f06-466a-bfa0-d9efe0a706c9 swap                    swap    defaults        0 0
#
#Additional Storage
UUID=fbf6dba9-4202-4654-9c87-cf114b058ce7 /run/media/bob/LinuxStorage ext4 rw,seclabel,nosuid,nodev,relatime,data=ordered 0 0
edit retag flag offensive close merge delete

Comments

Welcome to ask.fedora. You don't have to add a root account, it's there automatically, and in fact, you can't install without setting the root password, even if you don't remember it. If you don't believe me, run this command in a terminal: grep ^root /etc/password and see that the account's there.

sideburns gravatar imagesideburns ( 2017-10-20 13:46:38 -0500 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2017-10-20 13:57:12 -0500

sideburns gravatar image

updated 2017-10-20 13:59:16 -0500

Looking at your fstab, I see that you're attempting to mount that partition in a directory that doesn't yet exist. /run/media is only in RAM, and your own directory in it isn't created until you log in. In order to have it available at boot, it needs to be mounted in a directory that's always there, and the proper place for permanent mounts like this is /mnt.

sudo mkdir /mnt/bob
sudo chmod a+w /mnt/bob

will get you what you need, after which you simply use that mount point in fstab.

edit flag offensive delete link more

Comments

Thank you!

RushKing gravatar imageRushKing ( 2017-10-20 15:46:26 -0500 )edit

According to the LSB (Linux Standard Base) the /mnt directory is provided so that the system administrator may temporarily mount a filesystem as needed. Therefore it's not advisable to mount your filesystem there. Please consider some other mount point such as /storage or /data/storage or anything you like.

jmt gravatar imagejmt ( 2017-10-21 07:56:31 -0500 )edit

Shrug! I have an old Windows partition that I've been mounting to /mnt/WINDERZ at boot for over a decade because that's where I want it. The directory is there to be used however you want, so you might as well make use of it.

sideburns gravatar imagesideburns ( 2017-10-21 13:17:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-10-20 10:22:34 -0500

Seen: 155 times

Last updated: Oct 20 '17