Can't load Nvidia driver after upgrade from Fedora 25 to 26

asked 2017-11-05 09:46:50 -0500

drzee gravatar image

Hi, I upgraded Fedora to 26 and now the X Server doesn't start anymore. When I try to log in, the screen goes black and I end up at the login screen again. The X Server fails to start with "Fatal server error: no screens found". I compared the Xorg log that contains the error message (see below) with an old log from when the X Server was working: the line

xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)

didn't show up before, so maybe there is an issue with permissions? Do you have an idea how this can be fixed? I'm using the Nvidia driver from RPM Fusion and would prefer to continue using it instead of nouveau.

This is the full .local/share/xorg/Xorg.0.log file:

X.Org X Server 1.19.3
Release Date: 2017-03-15
[    36.452] X Protocol Version 11, Revision 0
[    36.452] Build Operating System:  4.10.6-200.fc25.x86_64
[    36.452] Current Operating System: Linux fedora 4.13.10-200.fc26.x86_64 #1 SMP Fri Oct 27 15:34:40 UTC 2017 x86_64
[    36.452] Kernel command line: BOOT_IMAGE=/vmlinuz-4.13.10-200.fc26.x86_64 root=/dev/mapper/fedora_linux-root ro rd.lvm.lv=fedora_linux/root rd.lvm.lv=fedora_linux/swap quiet rhgb LANG=de_DE.UTF-8 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau
[    36.452] Build Date: 23 April 2017  11:51:31PM
[    36.452] Build ID: xorg-x11-server 1.19.3-4.fc26 
[    36.452] Current version of pixman: 0.34.0
[    36.452]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    36.452] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    36.452] (==) Log file: "/home/christian/.local/share/xorg/Xorg.0.log", Time: Sun Nov  5 15:56:14 2017
[    36.452] (==) Using config file: "/etc/X11/xorg.conf"
[    36.452] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    36.452] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    36.453] (==) ServerLayout "Layout0"
[    36.453] (**) |-->Screen "Screen0" (0)
[    36.453] (**) |   |-->Monitor "Monitor0"
[    36.453] (**) |   |-->Device "Device0"
[    36.453] (**) |-->Input Device "Keyboard0"
[    36.453] (**) |-->Input Device "Mouse0"
[    36.453] (==) Automatically adding devices
[    36.453] (==) Automatically enabling devices
[    36.453] (==) Automatically adding GPU devices
[    36.453] (==) Automatically binding GPU devices
[    36.453] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    36.453] (**) FontPath set to:
    /usr/share/fonts/default/Type1,
    catalogue:/etc/X11/fontpath.d,
    built-ins
[    36.453] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    36.453] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    36.453] (WW) Disabling Keyboard0
[    36.453] (WW) Disabling Mouse0
[    36.453] (II) Loader magic: 0x823e00
[    36.453] (II) Module ABI versions:
[    36.453]    X.Org ANSI C Emulation: 0.4
[    36.453]    X.Org Video Driver: 23.0
[    36.453]    X.Org XInput driver : 24.1
[    36.453]    X.Org Server Extension : 10.0 ...
(more)
edit retag flag offensive close merge delete

Comments

I run proprietary, not rpm, and use dkms for automatic driver recompiles when kernel changes. I also use export CFLAGS="-march=native -O2" before I run the driver install, so that the compiler builds the driver with code specific to my processor. Seems to give me a slight FPS increase and better memory usage.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-11-05 13:35:05 -0500 )edit