Ask Your Question
1

Can't install Fedora Workstation 27 on Dell XPS 15

asked 2017-11-19 06:59:10 -0500

response404 gravatar image

Hello,

I have created a bootable USB stick, when I now want to boot from that USB stick on my Dell XPS 15 the installation gets stuck on this line: '[ OK ] Started User Manager for UID 1000'

Please tell me which other information I should provide.

Thank you in advance.

edit retag flag offensive close merge delete

Comments

Hello, provide some hardware specs (e.g. does it have nvidia GPU?). Are you installing in UEFI or legacy mode? Which tools / method / ISO did you use to create Live USB?

ozeszty gravatar imageozeszty ( 2017-11-19 09:40:48 -0500 )edit

I have exactly the same issue. Dell XPS 15 CNX95605; Windows 10 Home; Turned off 'Secure Boot'' and disabled RAID (activated AHCI) in BIOS. Downloaded 22.7 MB Fedora Media Writer for Windows and wrote to a new 16GB USB3.0 stick

psk gravatar imagepsk ( 2017-12-15 09:20:45 -0500 )edit

Try using image from https://dl.fedoraproject.org/pub/alt/... and use basic graphics mode (in troubleshooting sub-menu of GRUB). After installation you'll have to install Bumblebee and Nvidia driver. After that remove nomodeset from boot parameters.

I assume the issue is caused by Nvidia/nouveau issue.

ozeszty gravatar imageozeszty ( 2018-01-17 04:21:51 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-06-09 02:50:10 -0500

zeus338 gravatar image

updated 2018-06-09 02:55:01 -0500

I had the same problem on that machine and solved it as follows:

when the grub bootloader shows, hit 'e' to edit the fedora entry. At the bottom, you find a line similar to this one:

linuxefi /boot/vmlinuz-4.16.13-300.fc28.x86_64 nouveau.modeset=0 rd.driver.blacklist=nouveau rhgb quiet acpi_backlight=none acpi_osi=Linux acpi_osi=! acpi_osi='Windows 2009'

be sure to add the nouveau.modeset=0 rd.driver.blacklist=nouveau and acpibacklight=none acpiosi=Linux acpiosi=! acpiosi='Windows 2009" parts now. Then hit CTRL+X to run. The system will boot now past the '[ OK ] Started User Manager for UID 1000'. You can install fedora.

RIght after install, on first bootup, be sure to repeat the above step, otherwise it'll crash again right after you type your password.

Then, make the change permanent by modifying (with root):

cat /etc/default/grub   


GRUB_TIMEOUT=5  
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"  
GRUB_DEFAULT=saved  
GRUB_DISABLE_SUBMENU=true  
GRUB_TERMINAL_OUTPUT="console"  
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau resume=UUID=b4ff09ec-dfd6-4212-a6db-9ec73b37396b   nouveau.modeset=0 rd.driver.blacklist=nouveau rhgb quiet acpi_backlight=none acpi_osi=Linux acpi_osi=!   acpi_osi='Windows 2009'" 
GRUB_DISABLE_RECOVERY="true"

here, again the importanz parts concern nouveau and acpi. leave the rest unchanged. finally, run

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

now, on next startup, verify that the grub command line contains the changes. that should do it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-11-19 06:59:10 -0500

Seen: 682 times

Last updated: Jun 09 '18