Fedora 27 cURL error 7 on Wordpress Localhost

asked 2017-11-24 09:52:54 -0500

David-LDA gravatar image

Hello,

Since updating to Fedora 27 now Wordpress on localhost reports:

Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in ../wp-includes/update.php on line 347

and

RSS Error: WP HTTP Error: cURL error 7:

If I type this into the console, same error... related?

$  curl -6 google.com
curl: (7) Couldn't connect to server

How can I fix this?! THANKS

edit retag flag offensive close merge delete

Comments

from that it looks like connection is not working for you via IPv6. Have you tried turning off IPv6 and trying to reach it via IPv4 only?

masteroman gravatar imagemasteroman ( 2017-11-24 12:13:45 -0500 )edit

Tha is:

curl -4 google.com
villykruse gravatar imagevillykruse ( 2017-11-24 12:55:26 -0500 )edit

I have discovered my Wordpress errors go away and I can connect to the outside world again when I disable SELinux, but curl -6 on the command line still can't connect, and curl -4 can. Any idea how to tell SELinux to work without disabling it? Cheers, sorry about delay in reply.

David-LDA gravatar imageDavid-LDA ( 2017-11-30 05:58:23 -0500 )edit

I have discovered sudo setsebool -P httpdcannetwork_connect 1 fixes it, but I am a bit worried I am lowering my security by doing this... is this the best solution?!

David-LDA gravatar imageDavid-LDA ( 2017-11-30 06:39:14 -0500 )edit