Ask Your Question
1

[F27] Automatically Logs Out

asked 2017-11-29 02:52:40 -0500

Sieges gravatar image

Hi, Using Fedora 27 for my HTPC, and after updating to F27 from F26 the computer logs out and goes into hibernation mode overnight, cancelling all processes (except system processes) running. I have tried looking at all power and logoff setting and everything appears to be off. I have even installed Caffeine without effect. Nothing like this happened on F26. Any ides?

Thanks for any help! :)

edit retag flag offensive close merge delete

Comments

I think this is a quite unique problem and you have to do some debugging yourself to get it fixed. Hopefully I and others can assist you on the way:

I would try having a look at the logs (e.g. via journalctl, dmesg, maybe other logs) and hope to find out what causes the hibernation. (Maybe some cron or broken power setting?)

Does the hibernation happen at a specific time or after a specific timeout or random?

I am not that familiar with hibernation: Can you explain what the state of your computer is in the morning and why you thing it is hibernated?

dreua gravatar imagedreua ( 2017-12-01 10:07:23 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2017-12-03 12:04:10 -0500

Sieges gravatar image

Hmm... Further investigation would perhaps put this one at the TV. It appears to send "quit" or "suspend" commands to attached devices when you press the power button. When turing the TV off, the computer logs itself off. Very frustrating - my old Samsung did not do anything like this, and I cannot find anywhere in the settings on the new TV that would address this issue....

edit flag offensive delete link more

Comments

Have you tried just unplugging the HDMI cable? Same or different results?

dreua gravatar imagedreua ( 2017-12-03 19:16:26 -0500 )edit
0

answered 2017-12-03 03:33:16 -0500

Sieges gravatar image

Thank you for your reply.

I seem to have further "isolated" what is wrong. It seems to be related to a timeout when the TV is not active, a HDMI timeout setting or something. If I leave the TV on and don't use it - it's fine. But if I switch HDMI port to the Blue-Ray for Instance the sessions logs out after a while. The TV is a 2017 Samsung 65".

Thanks for any help

edit flag offensive delete link more

Comments

disable hdmi-cec on your tv. Then the tv will no try to turn off connected devices. My tv, satellite receiver and home theater all have hdmi-cec, and one device can turn the others on or off. Handy for me, so my wife only has to use one remote. Not handy, if the computer gets logged out, because of it though. Some devices let you set hdmi-cec per input, others it is system wide.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-12-05 15:11:30 -0500 )edit
0

answered 2017-12-03 19:22:12 -0500

dreua gravatar image

I think you are affected by Gnome-Shell Bug #1721428

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-11-29 02:52:40 -0500

Seen: 317 times

Last updated: Dec 03 '17