Ask Your Question
2

Fedora 27 doesn't recognize ThinkPad T420 Display

asked 2017-12-09 16:28:54 -0600

merlin gravatar image

updated 2017-12-09 16:40:54 -0600

Fresh install of Fedora 27 from Live USB did not recognize display. My T420 has integrated graphics card Intel HD graphics 3000 with HD+ 1600x900 Display.

I've tried running:

sudo dnf upgrade

to get the latest drivers and then restarted, but no luck.

Output of xrandr:

$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      61.00* 
   960x600        0.00  
   800x600       61.00

Please help point me in the right direction.

Thanks!

edit retag flag offensive close merge delete

Comments

Update: Tried to do another clean install, this time using Fedora 27 KDE Plasma Spin and display was successfully recognized. Thus, the issue seems to only exist in the normal Fedora 27 install with Gnome 3.

merlin gravatar imagemerlin ( 2017-12-09 22:02:20 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-12-12 17:20:48 -0600

ssieb gravatar image

If you want to use Gnome, try using the Xorg session instead of Wayland. After you click on your name to login, but before you enter the password, click on the little gear and select the Xorg session. If that works, then file a bug on Wayland at https://bugzilla.redhat.com/enter_bug... .

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-12-09 16:05:18 -0600

Seen: 344 times

Last updated: Dec 12 '17