Ask Your Question
1

Install bug - Fedora27 under Virtualbox (Windows platform)?

asked 2017-12-18 05:12:34 -0500

Alex80 gravatar image

Hi!

I downloaded Fedora 26 (earlier) and 27 from the getfedora.org .

When I install Fedora26 Server in the latest VirtualBox (Windows platform) everything works perfectly. When I install Fedora27 Server with the same parameters in the latest VirtualBox (Windows platform) the install process suddenly goes wrong: http://www.kepfeltoltes.eu/images/hdd...

Just blinking the content of the window and nothing happening. When I restart the virtual machine it seems work perfectly, but how can I be sure of it? Is there anybody who faced this problem?

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
1

answered 2017-12-20 11:40:03 -0500

florian gravatar image

You may want to run a dnf distro-sync to make sure your system is not partly installed.

Otherwise, if install keeps failing, install F26 server and upgrade tp F27

edit flag offensive delete link more

Comments

Yeah, it could be a good workaround!:) Okay, nobody faced this problem, so I will close the ticket. Many thanks!

Alex80 gravatar imageAlex80 ( 2017-12-21 07:02:17 -0500 )edit

I wouldn't be sure that nobody else faced that problem but maybe people didn't report, or went to other forums, or to VirtualBox, or ....

florian gravatar imageflorian ( 2017-12-21 09:48:55 -0500 )edit
0

answered 2017-12-18 22:22:07 -0500

rlbilljr gravatar image

I don't know if this will help or not but I was having problems installing Fedora 27 also. In my case i disabled 3d acceleration in virtual box settings / display. Just remove check mark next to enable 3d acceleration.

edit flag offensive delete link more

Comments

A update to virtual box just came out. You could try that. It improved things on my install of fedora 27. Don't forget to make sure guest additions is installed and updated also.

rlbilljr gravatar imagerlbilljr ( 2017-12-20 00:36:41 -0500 )edit

I updated my VirtualBox (now:5.2.4, previous: 5.2.2) and Extension Pack too, but the result is the same :(

Alex80 gravatar imageAlex80 ( 2017-12-21 06:54:32 -0500 )edit
0

answered 2017-12-19 02:24:15 -0500

Alex80 gravatar image

Hey, Thanks for the answer! However, I didn't mark 3d acceleration (disabled is the default). So there should be something else.

edit flag offensive delete link more
0

answered 2017-12-20 07:01:41 -0500

Alex80 gravatar image

I have found some side effect of the original problems:

1) During the install you can set new user. The install process didn't create home directory for this user(s). 2) httpd service install couldn't create apache user. 2) You cannot use useradd command, because: useradd: existing lock file /etc/passwd.lock without a PID And of course, there are two lock files: -rw-------. 1 root root 0 Dec 18 11:49 /etc/shadow.lock -rw-------. 1 root root 0 Dec 18 11:49 /etc/passwd.lock

So I think if you face this install problem under VirtualBox, you will have to well prepared :-)

edit flag offensive delete link more
0

answered 2018-03-23 10:56:56 -0500

mikioma gravatar image

I have exactly the same problem installing Fedora 27 server guest under Archlinux host or Fedora 27 workstation. Virtualbox updated to latest version, same error in both platforms.

Any clue about this issue?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-18 05:12:34 -0500

Seen: 647 times

Last updated: Dec 20 '17