Ask Your Question
2

rpmfusion nvidia driver doesn't load from kernel 14.4

asked 2017-12-21 05:48:44 -0500

kev0055 gravatar image

updated 2017-12-21 08:43:44 -0500

Hi,

Installed rpmfusion nvidia driver and was happy gaming on wine all the way until Fedora 27 kernel 14.4.x broke it completely, fails to load and fallback to nouveau driver instead. Now no more wine games. (Skyrim 10 FPS) No longer happy camper.

If I load kernel 14.3.x it works perfecty.

Tried reinstalling rpmfusion driver. No joy. Keep updating kernel to 14.4.6. No joy.

Oh, I believe in yesterday.

edit retag flag offensive close merge delete

Comments

yet another reason, i use proprietary and dkms. Never an issue with kernel updates, since fedora 24. I can copy and paste the steps I use, if needed.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-12-21 09:22:30 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2017-12-22 08:37:47 -0500

clnetbox gravatar image

updated 2017-12-22 08:45:58 -0500

You may want to consider changing the source (repository) of NVIDIA drivers.

First remove every NVIDIA related package you've installed from RPM Fusion.

Restart the system, then add the negativo17 repository and install the drivers.

  • sudo dnf config-manager --add-repo=https://negativo17.org/repos/fedora-nvidia.repo

  • sudo dnf update

  • sudo dnf install kernel-devel nvidia-driver nvidia-settings

  • sudo reboot

There are differences in the way the drivers are provided, just learn more here.

I have tested these drivers on fedora 27 with kernel 4.14 and everything works.

Another advantage is that you always get the latest stable NVIDIA GPU drivers.

edit flag offensive delete link more

Comments

Thanks, installed the negativo nvidia drivers without hitches but still loading nouveau.. until I saw this :

https://ask.fedoraproject.org/en/ques...

with solution of:

sudo akmods --force reboot


update: removed and reinstall again from software center as negativo nvidia is available there now. Also have to install the 32-bit drivers

dnf install nvidia-driver-libs.i686

to get my old wine games to work

kev0055 gravatar imagekev0055 ( 2017-12-27 22:32:57 -0500 )edit
0

answered 2018-04-08 11:38:25 -0500

kwizart gravatar image

The original issue in this report seems to be related to an old issue for :

sudo akmods --force

This is not needed anymore with current fedora (f26+)

Best is to use RPM Fusion packaged drivers in any cases.

edit flag offensive delete link more
0

answered 2018-03-29 10:34:18 -0500

Hi, I have the same problem since f25. Installed proprietary driver as in https://www.if-not-true-then-false.co... However, installing with DKMS does not help as I have to use a differently hacked proprietary driver with any major kernel change. This got really boring... Could you please be more specific about the "software center" from which you installed the driver? I cannot see any nvidia drivers in F27 repository...

Thanks, Igor

edit flag offensive delete link more

Comments

what do you mean differently hacked. I have NEVER had an issue with dkms and any minor or major kernel updates. Is your system pieced together from old outdated hardware?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-03-29 20:19:04 -0500 )edit

Yes, my card is rather outdated, it is GeForce GTS 250. Since 4.13, every NVIDIA prop. driver has to be patched with (almost) every kernel change. When DKMS tries to compile a new module for a new kernel, it fails. So every time I have to repeat the whole procedure from "if-not-true-then-false" guide, downloading a new patched driver...

Yet, the card's capabilities are more than sufficient for my (working) environment. Moreover, there are several computers in my department which all have identical hardware. So I would prefer a software solution (if possible) to hardware change...

Igor.Antokhin gravatar imageIgor.Antokhin ( 2018-03-30 03:37:42 -0500 )edit

checked and the drivers for your card are EOL by nvidia, so you are stuck, having to patch drivers, and if I had the means, I would send you one of my unused 550 and you could at least be able to enjoy an easier life with your computer.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-03-31 10:07:18 -0500 )edit

Thanks for your answer and kindness :) I need 5 cards :) Well, eventually I will replace them all. What a world - I have to trash perfectly adequate and working hardware just because it is not supported any more...

Igor.Antokhin gravatar imageIgor.Antokhin ( 2018-04-02 03:13:09 -0500 )edit

I only have one, but I am serious about gifting it to you, as long as you live in the United States, since shipping overseas is harder for computer parts. Or, you could simply stay on the software version that works, and not constantly update. As new software comes out, it has to move forward, with the technology, because the consumers want the best toys to play with. I was happy with Dos and CPM on a monochrome monitor, with 4k ram and 8 inch floppy drive. Progress is a double edged sword, in the loss of use of older hardware, just because no one wants to use it anymore.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-04-04 11:35:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-21 05:48:44 -0500

Seen: 1,185 times

Last updated: Apr 08 '18