Ask Your Question
0

How can I use Nvidia Optimus on Fedora 27?

asked 2018-01-05 05:37:41 -0600

scrat98 gravatar image

Hello. I have Dell XPS 15 9560 with NVIDIA GTX 1050 (Mobile). Also I have Intel graphics. So, I want to use Nvidia X Server to choose what graphic card I use or what profile (auto, perfomance or energy saving) with Nvidia Optimus driver. Firstly, I've install Ubuntu 16.04, but when I use lspci my laptop freezes and system is crashed. Ubuntu can't find my NVIDIA graphics, so I've decide to install Fedoro 27. It's looks great - lspci find Intel and 3D Nvidia Controller. I read these arcticals:
1. This is for non optimus devices https://rpmfusion.org/Howto/NVIDIA (how can I understand).
After this

dnf install xorg-x11-drv-nvidia akmod-nvidia
dnf update -y

I cant load Nvidia X Server with error "unable to find display on any available system". But all looks great. Looks like Nvidia Optimus done, but it doesn't

2.This is for Optimus devices http://fedoraproject.org/wiki/Bumblebee

It's been updated a couple of hours ago, but after "Installation (NVIDIA Proprietary)" I've got a black screen and can't boot

P.S. Recently nvidia have released 384.111 driver January 4, 2018 (as you can see here http://www.nvidia.com/Download/Find.a... ), but rpmfusion and negative017 give me old driver (387.34 November 24, 2017)

So, how can I use Nvidia Optimus on Fedora 27? Thanks to everyone

edit retag flag offensive close merge delete

Comments

I had looked at it sometime ago and given up. The bumblebee page was recently updated so you may want to re-check. There are specific versions of the nvidia driver that apply to different devices, and I'm not sure if all these drivers support the switching bit. At the moment, nouveau works for me (although I haven't been gaming etc, so i'm not really using it as others would I reckon).

FranciscoD_ gravatar imageFranciscoD_ ( 2018-01-05 08:56:49 -0600 )edit

Nvidia releases updates to series of drivers - and each series supports different hardware and different features (or so I thought when I'd looked last).

FranciscoD_ gravatar imageFranciscoD_ ( 2018-01-05 08:57:48 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-12-30 14:45:58 -0600

q2dg gravatar image

updated 2018-12-30 20:19:58 -0600

I've achieved using Nvidia Optimus on Fedora 29. I know it's not the same version of Fedora you were asking about, but it's what I'm currently running. If you don't mind to update your distro, I hope my experience can help you. I explain necessary steps below.

PREVIOUS 1.-First, disable Secure Boot from BIOS. As far as I know, akmod-nvidia will rebuild nvidia kernel modules for each new kernel, and with secure boot enabled you can run into situation when system won’t load these newly-built unsigned kernel modules.

PREVIOUS 2.-Boot from a Fedora Workstation Live environment. This will work flawessly (Ubuntu Live works very well, too). Install this system on SSD as you like. Everything will installed ok but, once installed system reboot first time, it will begin to hang at random times without any possibility of resume. Very fustrating. The problem comes from using the "nouveau" driver, which simply doesn't work.

So...

1.-Boot again from any Live environment (I suspect that there's no issues inside this environment because Intel's GPU is choosen there instead of Nvidia's one, but I should confirm it). Open a terminal and mount the root-filesystem's partition where you installed Fedora, anywhere (for instance, if /mnt/system is the mount point and /dev/sda1 the partition where is the Fedora's "/" ): mount /dev/sda1 /mnt/system

2.-The plan is to enter inside this partition to get into a "chroot" environment to be able to execute some commands there to discard the use of "nouveau" driver at its boot (I must execute them inside the faulty system but because I can't use it, I enter into it from an usable system, the Live environment). In summary, the easiest way to do this is execute (as root) this command: systemd-nspawn -bD /mnt/system

3.-Once inside the Fedora chroot, you must execute following commands, which will install the official Nvidia driver (it's not open-source): dnf install fedora-workstation-repositories <- This package only exists from Fedora 28 onwards, sorry dnf config-manager --set-enabled rpmfusion-nonfree-nvidia-driver dnf install xorg-x11-drv-nvidia

The NVIDIA repo used above automatically blacklists the nouveau driver at the boot time adding these parameters to GRUB_CMDLINE_LINUX line in /etc/default/grub file: "rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1" so you don't need edit anything.

4 (OPTIONAL). There's one detail you could consider, though. Official Nvidia driver doesn't allow choose between Intel graphical card and Nvidia's one: the latter is ALWAYS used. If you aren't a gamer, maybe you'd prefer the inverse (that's is, to use only the Intel graphical device) because it drains a lot less of battery or because you want to use Wayland instead of Xorg (official Nvidia driver doesn't work on Wayland!!),etc. To achieve that, you should delete the GRUB_CMDLINE_LINUX line's parameters you wrote in step 3 and add these ones instead: "rd.driver.blacklist=nouveau,nvidia ... (more)

edit flag offensive delete link more
0

answered 2018-02-26 09:09:35 -0600

Try this!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-05 05:35:05 -0600

Seen: 5,347 times

Last updated: Dec 30 '18