Ask Your Question
1

Gnome Authentication Error When Logging in After Lock

asked 2018-01-05 12:27:38 -0500

jesserosenbaum gravatar image

When I try to log into my ThinkPad W540 running Fedora 27 after my session locks I get an authentication error and I am unable to log in. I try clicking on 'Use a Different User' and then clicking on myself again I don't get a chance to enter my password. Eventually I get the same authentication error and my only way to recover is to reboot, which is very frustrating as you could imagine. I tried pressing CTL + ALT + F1, but get no response.

I saw some old posts around Fedora 22 about systemd 204 being the issue and it was fixed in systemd 207, but I have to imagine that the systemd version in Fedora 27 is at 207 or higher. What would someone need to help troubleshoot this issue? I would hate to re-image my PC. I suppose I could try switching to KDE to see if it makes a difference, but I'd rather not as I prefer Gnome. Thank you for taking the time to review this.

  • Jesse
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2018-02-08 03:21:28 -0500

laoist gravatar image

updated 2018-02-18 18:51:12 -0500

Hey man,

I've been having the same issue on my ThinkPad X1 lately and am also running Fedora 27.

Authentication error was reproduced consistently by locking my screen and majority of the time I had to restart to resolve.

Kernel Version: 4.14.16-300.fc27.x86_64

Error: Unexpected system error with kernel-core

Detail: Tainted modules: vboxpci, vboxnetadp, vboxnetflt, vboxdrv

I noticed this issue occurring since a recent install of VirtualBox, and as such I've removed it and any related packages. Following that, I've not had any authentication errors.

Not sure if you're using this too, but may be worth a shot. Couldn't really find any other issues aside from the one highlighted above.

Cheers,

Josh


EDIT: 19th February, 2018

Thought I'd drop back in and say I found what the issue was for me with absolute certainty:

Link

Temporary solution:

sudo -i
echo 1048576 > /proc/sys/fs/inotify/max_user_watches
exit

Permanent solution:

Edit /etc/sysctl.conf

fs.inotify.max_user_watches=1048576

Whilst the above link doesn't relate to the same issue we're all experiencing, the solution did actually fix the problem for me. In my situation I do have Crashplan installed, but you guys may not.

Link to information from Crashplan:

Link

edit flag offensive delete link more

Comments

Thank you, that solved the problem for me too. I can't upvote you because my account is too green.

jblugagne gravatar imagejblugagne ( 2018-03-20 11:15:19 -0500 )edit
0

answered 2018-02-19 05:45:04 -0500

2laoist, you awesome, it WORKS! Thank you!

edit flag offensive delete link more
0

answered 2018-02-15 00:15:42 -0500

Same problem. 4.14.18-300.fc27.x8664, gnome-shell-3.26.2-4.fc27.x8664. After screen lock I can't unlock. Need to reboot. Deleting of virtualbox doesn't help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-01-05 12:27:38 -0500

Seen: 2,915 times

Last updated: Feb 18 '18