Ask Your Question
1

Mount partition at boot

asked 2018-01-14 14:10:18 -0500

Hasheurr gravatar image

Hello I'm trying to do that: "- Create a “Windows” directory on home directory of user account - This “Windows” directory must be automaticaly mount on startup with the home user directory in the Windows partition with read/write access (WARNING: Only user home, no full disk !)"

But I don't know if i need to use fstab and if i need to use it, I don't know how i can use it, i try that

/dev/sda1   /mnt/win   ntfs-3g   defaults,auto,uid=1000,gid=1000,user   0   0

But it open the rescue mode...

Thank's for your help

edit retag flag offensive close merge delete

Comments

can you show us the output of lsblk?

Phoenix_masshhad gravatar imagePhoenix_masshhad ( 2018-01-16 14:15:57 -0500 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2018-01-18 22:47:44 -0500

SteveEbey73701 gravatar image

How about this, have you turned off fast shutdown, so windows actually dismounts, so that fedora can mount properly? You MUST disable fast shurdown in Windoze before any Windoze drives can be mounted. Once that is done, then the other answers will probably work.

edit flag offensive delete link more
0

answered 2018-01-14 16:44:04 -0500

sideburns gravatar image

Welcome to ask.fedora. The first thing you need to do if you haven't already is create the directory /mnt/win so that mount can use it. Second, change the mount options to simply umask=0000 because otherwise it's likely to be mounted read only, no matter what other options you use. Using either auto or user is redundant, as the default is to mount it at boot, so allowing it to be mounted without root access isn't needed. Good luck, and let us know if this helps.

edit flag offensive delete link more
0

answered 2018-01-16 14:20:12 -0500

Phoenix_masshhad gravatar image

updated 2018-01-16 14:20:37 -0500

/dev/sda1 /mnt/win  ntfs defaults 1 2
edit flag offensive delete link more

Comments

That should work, provided that it doesn't end up read only, as I mentioned below. However, you're probably better off finding and using the partition's UUID, because the partitions are numbered in the order they respond to probing and might not always be the same. Or, you can give the partition a label and use that for the same reason.

sideburns gravatar imagesideburns ( 2018-01-16 15:28:26 -0500 )edit
0

answered 2018-01-14 16:52:22 -0500

abadrinath gravatar image

Potentially a hard-drive error? sideburns' answer seems more likely, but it's possible. Does it mount fine when you're logged in?

Can you show us the output of fdisk -l?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-01-14 14:10:18 -0500

Seen: 333 times

Last updated: Jan 18 '18