When starting a VirtualBox VM, I get

asked 2018-01-28 18:50:06 -0500

EnriqueGLez gravatar image

updated 2018-01-28 22:08:56 -0500

WARNING: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (4.14.14-300.fc27.x86_64) or it failed to load. Please recompile the kernel module and install it by

       sudo /sbin/vboxconfig

VirtualBox Kernel driver not installed (rc=-1908) after kernel upgrade Fedora 27
edit retag flag offensive close merge delete

Comments

VirtualBox is not a Fedora Package and the kernel modules are not maintain by Fedora, so each time you run dnf update and the kernel gets updated you need to compile the VirtualBox kernel module. You have two options there to compile it or run Fedora with the Kernel Version that was working before. Best option is to use kvm virtualization which is native on Fedora and use Virtual-manager to manage.

aeperezt gravatar imageaeperezt ( 2018-01-28 23:30:10 -0500 )edit

There should be an akmod for VirtualBox. This way VB kernel module is rebuilt when you reboot.

fcomida gravatar imagefcomida ( 2018-01-29 06:38:29 -0500 )edit

No need to recompile kernel modules manually if you have dkms installed (also requires kernel-headers, kernel-devel, and maybe others). Search this site - this questions has been asked and answered many times. You need to installed dkms before installing VirtualBox so that the modules get registered correctly with dkms.

florian gravatar imageflorian ( 2018-01-29 16:39:08 -0500 )edit

I'd recommend installing VirtualBox from rpmfusion. It drags in all the needed kernel mods and then all you need to do after an upgrade is restart to allow the new kernel mods to install.

Mordoc gravatar imageMordoc ( 2018-01-29 16:45:28 -0500 )edit

Same happening when using dkms

florian gravatar imageflorian ( 2018-01-30 04:49:43 -0500 )edit