Ask Your Question
0

Fedora 27 -Why WiFi doesn't work in kernel 4.15.3

asked 2018-02-16 23:22:13 -0500

dchatterjee gravatar image

updated 2018-02-17 00:36:40 -0500

output of sudo akmods --forcehttps://hastebin.com/afigaxuwop.cs
I think this log should be enough. If you want any additional log please comment.
akmod-wl.x86_64 version :- 6.30.223.271-15.fc27

edit retag flag offensive close merge delete

Comments

I also have the same issue.

suvretta gravatar imagesuvretta ( 2018-02-17 17:02:30 -0500 )edit

5 Answers

Sort by » oldest newest most voted
2

answered 2018-02-17 17:43:11 -0500

vvvvvvvvvv gravatar image

The problem is fixed on the latest version wl-mod

For more info see https://bugzilla.rpmfusion.org/show_bug.cgi?id=4798

edit flag offensive delete link more

Comments

Yes, I can confirm that - with the latest update - the issue is fixed (akmods --force as root).

pvitt72 gravatar imagepvitt72 ( 2018-02-18 06:15:52 -0500 )edit

It works with the new fix. Thanks for the answer.

kiko964 gravatar imagekiko964 ( 2018-02-18 07:47:38 -0500 )edit
0

answered 2018-02-17 02:44:24 -0500

pvitt72 gravatar image

Same problem to me. This is the relevant part of the log:

2018/02/17 09:35:08 akmodsbuild: /tmp/akmodsbuild.AcK04fj9/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.15.3-300.fc27.x86_64/src/wl/sys/wl_linux.c:2369:2: error: implicit declaration of function 'init_timer'; did you mean 'init_timers'? [-Werror=implicit-function-declaration]
2018/02/17 09:35:08 akmodsbuild: init_timer(&t->timer);
2018/02/17 09:35:08 akmodsbuild: ^~~~~~~~~~
2018/02/17 09:35:08 akmodsbuild: init_timers
2018/02/17 09:35:08 akmodsbuild: /tmp/akmodsbuild.AcK04fj9/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.15.3-300.fc27.x86_64/src/wl/sys/wl_linux.c:2370:10: error: 'struct timer_list' has no member named 'data'
2018/02/17 09:35:08 akmodsbuild: t->timer.data = (ulong) t;
2018/02/17 09:35:08 akmodsbuild: ^
2018/02/17 09:35:08 akmodsbuild: /tmp/akmodsbuild.AcK04fj9/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.15.3-300.fc27.x86_64/src/wl/sys/wl_linux.c:2371:20: error: assignment from incompatible pointer type [-Werror=incompatible-pointer-types]
2018/02/17 09:35:08 akmodsbuild: t->timer.function = wl_timer;
2018/02/17 09:35:08 akmodsbuild: ^
2018/02/17 09:35:08 akmodsbuild: cc1: some warnings being treated as errors
2018/02/17 09:35:08 akmodsbuild: make[1]: *** [scripts/Makefile.build:317: /tmp/akmodsbuild.AcK04fj9/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.15.3-300.fc27.x86_64/src/wl/sys/wl_linux.o] Error 1
2018/02/17 09:35:08 akmodsbuild: make: *** [Makefile:1512: _module_/tmp/akmodsbuild.AcK04fj9/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.15.3-300.fc27.x86_64] Error 2
edit flag offensive delete link more

Comments

Hi everyone i am new on Fedora. I am having the same problem did anyone solved it?

vvvvvvvvvv gravatar imagevvvvvvvvvv ( 2018-02-17 06:54:55 -0500 )edit
0

answered 2018-04-24 01:25:05 -0500

updated 2018-04-24 02:03:35 -0500

Is this still an ongoing issue? I tried using sudo akmods --force, after installing akmods to my Fedora 27 (4.15.17-300.fc27.x86_ 64) and received "No akmod package found, nothing to do", yet whenever I try to install the driver I need to get my Wifi Adapter to work, I get an error with the 'init_ timer'. It happens whenever I try to use make. Can someone help, is this a user error, or something bigger. Below is my error:

[albbravo@pendragonlinuxhome rtl8812au]$ make make ARCH=x8664 CROSSCOMPILE= -C /lib/modules/4.15.17-300.fc27.x86_ 64/build M=/home/albbravo/rtl8812au modules make[1]: Entering directory '/usr/src/kernels/4.15.17-300.fc27.x86_ 64' CC [M] /home/albbravo/rtl8812au/core/rtw_ cmd.o In file included from /home/albbravo/rtl8812au/include/osdep_ service.h:41:0, from /home/albbravo/rtl8812au/include/drv_ types.h:32, from /home/albbravo/rtl8812au/core/rtw_ cmd.c:22: /home/albbravo/rtl8812au/include/osdep_ service_ linux.h: In function ‘_ init_ timer’: /home/albbravo/rtl8812au/include/osdep_ service_ linux.h:257:8: error: ‘_ timer {aka struct timer_ list}’ has no member named ‘data’ ptimer->data = (unsigned long)cntx; ^~ /home/albbravo/rtl8812au/include/osdep_ service_ linux.h:258:2: error: implicit declaration of function ‘init_ timer’; did you mean ‘_ init_ timer’? [-Werror=implicit-function-declaration] init_ timer(ptimer); ^~~~~~~~~~ _ init_ timer cc1: some warnings being treated as errors make[2]: * [scripts/Makefile.build:325: /home/albbravo/rtl8812au/core/rtw_ cmd.o] Error 1 make[1]: [Makefile:1527: _ module_ /home/albbravo/rtl8812au] Error 2 make[1]: Leaving directory '/usr/src/kernels/4.15.17-300.fc27.x86_ 64' make: ** [Makefile:1052: modules] Error 2

edit flag offensive delete link more
0

answered 2018-02-17 08:59:37 -0500

I am facing the same issue.

edit flag offensive delete link more

Comments

please check whether you are facing same kind of error. run sudo akmods --force
paste the output of the log file here here

dchatterjee gravatar imagedchatterjee ( 2018-02-17 12:41:13 -0500 )edit

Yes it is the same error. Here is the log output https://pastebin.com/fwvdz8Ry

Shifaat I. gravatar imageShifaat I. ( 2018-02-17 14:28:49 -0500 )edit
0

answered 2018-02-17 12:27:46 -0500

Same issue here. There is no problem with kernel 4.14.18 on fedora 27, but no wifi with kernel 4.15.3.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-02-16 23:22:13 -0500

Seen: 1,103 times

Last updated: Apr 24