Failed to boot and fallback to grub minimal bash on every kernel update

asked 2018-03-03 06:48:57 -0500

Vibol gravatar image

Hello,

I'm unable to boot on every new kernel update. My system always fallback to Grub minimal bash like

Minimal BASH like line editing is supported. Boot error on Fedora

Try to resolution suggested by the post above is fixed but.. The problem still reproduce when i receive new kernel update. So i have to manual fix the problem again again

Remark:

HP Z400 mother board 16GB ram AMD gpu with opensource mesa driver (by default)

SSD hard drive /dev/sda1 as root partition (bios, mbr, xfs)

HDD hard drive /dev/sdb2 as home partition (mbr)

FYI on first installation

  1. Boot Fedora workstation netinstall 27 to usb (sha256sum checked)
  2. select option 1 minimal install (basic functionality)
  3. when complete reboot and eject usb and start install gnome with > dnf install @base-x gnome-shell && systemctl enable gdm && systemctl set-default graphical.target
  4. Reboot and use the system with normal

Cheer! :)

edit retag flag offensive close merge delete

Comments

have you tried proprietary drivers from amd to see if the problem goes away?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-03-03 09:40:17 -0500 )edit

@steveebey73742. I maybe wrong but there nothing to do with the priority driver of amd as i may think because it look like grub forget to run grub2-mkconfig -o /boot/grub2/grub.cfg after a new kernel is updated for some reason.

Please refer to my link for more explain of the problem.

Vibol gravatar imageVibol ( 2018-03-03 19:16:54 -0500 )edit

Please check: https://bugzilla.redhat.com/show_bug.... comments 6 & 7. Fedora does NOT run grub2-mkconfig after kernel upgrades. It tries to modify your current grub.cfg directly.

hedayat gravatar imagehedayat ( 2018-03-17 16:26:13 -0500 )edit

@hedayat Grub not working properly when running on efi mode is a bug... but i'm not running on EFI mode

Vibol gravatar imageVibol ( 2018-06-14 10:22:25 -0500 )edit