fedora 27 slow boot

asked 2018-03-03 08:34:40 -0500

ahfm gravatar image

my fedora is too slow this is my systemd-analyze blame output can i diable some of packages

[root@dhcppc3 ahfm]# systemd-analyze blame
     41.289s plymouth-quit-wait.service
     22.698s NetworkManager-wait-online.service
     16.327s systemd-journal-flush.service
     12.287s firewalld.service
     10.517s lvm2-monitor.service
      9.719s dev-mapper-fedora\x2droot.device
      9.543s udisks2.service
      9.418s systemd-udev-settle.service
      9.141s cups.service
      8.767s libvirtd.service
      8.508s initrd-switch-root.service
      7.844s sssd.service
      6.796s abrtd.service
      4.920s ModemManager.service
      4.560s polkit.service
      3.981s gssproxy.service
      3.727s systemd-fsck-root.service
      3.594s livesys.service
      3.553s switcheroo-control.service
      3.538s rtkit-daemon.service
      3.334s colord.service
      2.960s dracut-initqueue.service
      2.899s systemd-udevd.service
edit retag flag offensive close merge delete

Comments

How does it take to boot?

Is connecting to your network slow? NetworkManager-wait-online might slow down your boot if it takes a while to connect to network.

hedayat gravatar imagehedayat ( 2018-03-17 16:18:23 -0500 )edit

Is there a way to make the system boot without waiting to join a network?

heybuddy gravatar imageheybuddy ( 2018-04-29 08:16:50 -0500 )edit

Yes, probably the easiest is to mask NetworkManager-wait-online, but some services might not function correctly. Probably a better approach is to disables services which depend on network-online.target.

hedayat gravatar imagehedayat ( 2018-05-10 07:00:08 -0500 )edit