Ask Your Question
3

Fan control with nouveau driver

asked 2018-03-15 06:40:41 -0500

Onox gravatar image

updated 2018-03-15 06:48:45 -0500

Hi ! I have a Zotac GeForce GTX 1070 AMP! graphics card, which is designed so that its fans shouldn’t spin at all on a low load ; in fact, not until the temperature becomes fairly high, which doesn’t happen unless I’m playing a 3D game. This works very well on Windows, but on Fedora, the fans always spin whatever the load, which is obviously not good for their lifespan.

Is there any hope of controlling the fan speed with the nouveau driver ? Using those documentation pages : arch linux – fan control ; nouveau thermal , I tried setting my pwm1_enable value (in /sys/devices/pci0000:00/0000:00:03.1/0000:0e:00.0/hwmon/hwmon0) to 0 or 1 (with pwm1 == 0 for the latter, which seems to be the default value anyway), but this had absolutely no effect.

Is the card too badly supported by the free driver yet for fan control to work at all (I’m well aware that nvidia is bad regarding Linux support :( ) ? Or could something else be controlling the fan speed ? I was wondering whether the card has its own static memory in addition to its BIOS, because after I used Zotac’s program (FireStorm) to turn off the illuminated "GeForce" logo, it stays off even outside of Windows.

I also tried to install the proprietary nvidia driver with the akmod, but it just crashed during boot and I was forced to uninstall it. Anyway, I have no plans to play on Fedora, and I only need basic display, so I have no reason to install the proprietary driver unless it allows the fans not to spin on low load.

What else can I try ? Thank you in advance for any answer !

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2018-03-16 16:24:30 -0500

SteveEbey73701 gravatar image

updated 2018-03-16 16:24:59 -0500

Proprietary is the only way i know of to get full fan control. Even with proprietary, you do have to run nvidia-xconfg --cool-bits=12 so that the nvidia-settings program will allow fans and performance adjustments. You will have to disable the nouveau driver, before the nvidia driver will run. You can have the run file from nvidia do that for you, by adding -Z (be sure it is uppercase Z) to the run command. After the driver finishes building, you can use nvidia-xconfig --cool-bits=12 to set the card up.

edit flag offensive delete link more

Comments

Thanks a lot for your answer. I managed to install the proprietary driver, and indeed the fans stopped spinning when the temperature is low. I didn’t need to use the coolbits settings or to disable nouveau, but I installed the special version of mutter with eglstream support (explained here). Not 100 % sure this was the problem in the first place, but at least it works now

Onox gravatar imageOnox ( 2018-03-21 06:29:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-15 06:40:41 -0500

Seen: 823 times

Last updated: Mar 15 '18