Ask Your Question
1

Gnome-Shell cpu issue

asked 2018-03-24 07:54:53 -0500

Ghorin gravatar image

updated 2018-03-24 15:44:18 -0500

florian gravatar image

Hello,

I have an issue since yesterday on my Fedora 27 : an very high cpu loading on Gnome Shell. I have test with earlier kernel and this is the same (4.15.10-300, 4.15.8-300, 4.15.6-300)

What's happening :

  • in GDM : lot of mouse freezing
  • in Gnome Shell : lot of mouse freezing, cput high load by Gnome Shell process (400%) (and some also by tracker-extract)

Error message in dmesg :

[drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CTRL:32:crtc-0] flip done timed out
[drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:30:plane-0] flip done timed out
[drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:31:plane-1] flip done timed out
[drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CONNECTOR:43:DVI-I-1] flip done timed out

My system is up-to-date (dnf update). Last modification done was uninstall and re-installation of akmod-nvidia (it was installed since a long time but it was ko since several kernel updates with "kernel driver not found" at system start). Now the nvidia driver is loading find (lsmod | nvidia => nvidia modules loaded).

I've tried with both X11 and Wayland => same result

I have found in the net this is a gdm/mutter issue and that solution is to switch to another DM like lightdm. Which i don't like much (i prefer sticking to the official Gnome softwares).

Well if you have any idea to understand and correct that issue, i thank you in advance.

Eric

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-03-24 19:20:11 -0500

Ghorin gravatar image

More information : I have removed nvidia driver and i have replaced it with nouveau driver and ... no more issue. ==> the issue comes from nvidia driver on my computer. I wonder if it could come from the following line in my grub.cfg :

modprobe nvidia-drm modeset=1

Tomorrow i might try te re-install nvidia driver and test without that line.

Any other idea ?

edit flag offensive delete link more
0

answered 2018-03-25 17:32:28 -0500

lsatenstein gravatar image

Are you running Gnome with Extensions. As a test, disable the extensions. If that solves the problem, then one by one, restore the exensions.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-03-24 07:54:53 -0500

Seen: 1,597 times

Last updated: Mar 25 '18