Ask Your Question
1

modprobe: ERROR: could not insert 'rtl8723de': Required key not available

asked 2018-03-24 12:01:15 -0500

nmorgan9999 gravatar image

I have been trying to install a driver for the RTL8723DE (aka RealTek d723) on a new HP laptop so that I can get wifi working. I am using the current version of Fedora 27 and "$ dnf update" says that I am up to date (March 24, 2018). A range of help pages give instructions for downloading a driver and installing the driver. Unfortunately, I get an error on the last step when using modprobe.

$ sudo modprobe -v rtl8723de antsel=2 insmod /lib/modules/4.15.10-300.fc27.x8664/extra/rtlwifi.ko.xz modprobe: ERROR: could not insert 'rtl8723de': Required key not available

The Kernel module rtl8723de appears to be installed. The result from "$ lspci -k" shows that the kernel module is installed.

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device d723 Subsystem: Hewlett-Packard Company Device 8319 Kernel modules: rtl8723de

I have rebooted the machine but it doesn't solver my problem. I am seeking help resolving the problem of why I cannot get the kernel driver to be used. Very thankful for any help.

For clarity purposes,

I installed dkms using "$ dnf install dkms"

I installed kernels using $ dnf install kernel-devel.x86_64$

I installed kernel headers using "$ dnf install kernel-headers.x86_64"

I installed the driver using the following commands from my "download folder":

$ git clone -b extended --single-branch https://github.com/lwfinger/rtlwifi_n... unofficial

$ cd rtlwifi-new

$ sudo dkms add ../rtlwifi_new

$ sudo dkms build rtlwifi-new/0.6

$ sudo dkms install rtlwifi-new/0.6

The last command is "$sudo modprobe -v rtl8723de ant_sel=2" which does not work (please see beginning of message).

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
4

answered 2018-03-24 13:37:08 -0500

fcomida gravatar image

Disable secure boot or learn how to sign a module: Signing Kernel Modules for Secure Boot

edit flag offensive delete link more
0

answered 2018-03-24 16:44:12 -0500

nmorgan9999 gravatar image

An update... There is good news and bad news. The good news is that I am now using the kernel driver. Big thanks to the fcomida for the help. The bad news is that I cannot see any wifi networks. Here are the commands and notes for what I have done.

$ install dnf mokutil

I ran "$ mokutil --disable-validation" and set a password.

On reboot, I was given a prompt to run the MOK utility. I had to press a key within 10 seconds to enter the utility I then choose "modify MOK config", entered the password, and chose to disable secure boot. The password required that I enter a single letter of the password (e.g., 4th letter in the password) multiple times.

I was able to successfully run the command

$sudo modprobe -v rtl8723de ant_sel=2

The driver is now used. "$lspci -k" gives

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device d723

Subsystem: Hewlett-Packard Company Device 8319

Kernel driver in use: rtl8723de

Kernel modules: rtl8723de

Again, a big thanks to fcomida for the help.

The bad news is that I do not see any wifi networks. "$ ncli radio wifi" returns enabled. But "$ nmcli device wifi rescan" returns.

Error: Scanning not allowed while unavailable or activating.

Likewise, "nmcli device status" returns

wlo1 wifi unavailable --

Help with the next problem is greatly appreciated.

edit flag offensive delete link more

Comments

Please post dmesg output.You can use fpaste for it.

fcomida gravatar imagefcomida ( 2018-03-25 06:56:14 -0500 )edit

Thank you for the help. The output from dmesg, using fpaste, is available at

https://paste.fedoraproject.org/paste...

nmorgan9999 gravatar imagenmorgan9999 ( 2018-03-25 08:30:41 -0500 )edit

So it seems you forgot to put the firmware rtl8723defw.bin into /lib/firmware/rtlwifi/

fcomida gravatar imagefcomida ( 2018-03-25 10:28:00 -0500 )edit

Thanks so much for everything! Your advice was fantastic. Wifi works!

Some additional updates for others who have troubles with wifi and the RealTek card. Please ensure that you clone the correct branch from git hub that has this file. Next, the signal strength is poor, but easily fixed by typing "$modprobe -v rtl8723de ant_sel=2" and creating a file called "rtl8723de.conf" that is located in

/etc/modprobe.d/rtl8723de.conf

This file has the following text in it

options rtl8723de ant_sel=2

I now have excellent wifi strength and speed. Thanks again for the help.

nmorgan9999 gravatar imagenmorgan9999 ( 2018-03-25 13:12:57 -0500 )edit

The ant_sel number depends on which connection the laptop manufacturer connected the antenna to.

ssieb gravatar imagessieb ( 2018-03-25 18:58:09 -0500 )edit
0

answered 2018-04-24 23:37:45 -0500

Walker82 gravatar image

Can anyone help me with this. I have the same problem. I've installed the driver and used mokutil to disable secure boot, but when I tried modprobe that was my result:

sudo modprobe -v rtl8723de ant_sel=2
insmod /lib/modules/4.15.17-300.fc27.x86_64/kernel/drivers/net/wireless/realtek/rtlwifi/rtlwifi.ko.xz 
modprobe: ERROR: could not insert 'rtl8723de': Exec format error

So I dont know how to go forword.

Any tips?

Some more infos:

$ lspci -k | grep -i real
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device d723
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

$ dmesg | grep -i wireless
[   19.304132] input: HP Wireless hotkeys as /devices/virtual/input/input6
$ dmesg | grep -i network
[    1.608125] drop_monitor: Initializing network drop monitor service
[    9.685935] SELinux:  policy capability network_peer_controls=1
[    9.685938] SELinux:  policy capability always_check_network=0
$ dmesg | grep -i realtek
[    2.588044] usb 1-5.3: Manufacturer: Realtek
[   22.310456] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC3227: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[   22.310461] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   22.310463] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[   22.310465] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[   22.310466] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[   22.310470] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x19
[   22.310472] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12

Complete dmesg at: https://paste.fedoraproject.org/paste...

edit flag offensive delete link more

Comments

Is your system correctly up to date? rtlwifi has been compiled for kernel-4.15.16 (see dmesg). Anyway your card needs rtl8723de driver, post dmesg output after you modprobe that module.

fcomida gravatar imagefcomida ( 2018-04-25 05:15:40 -0500 )edit
0

answered 2018-06-27 03:38:53 -0500

Ted23 gravatar image

/usr/sbin/modprobe is a link to /usr/bin/kmod, modprobe is looking for /sbin/modprobe when run from the command line

Solution: cd /sbin ln -s /usr/bin/kmod modprobe This makes a link in /sbin/modprobe to /usr/bin/kmod modprobe should work now

THIS IS A BUG AND SHOULD BE REPORTED!!!

edit flag offensive delete link more

Comments

/sbin is a symbolic link to /usr/sbin on fedora systems.

ls -lLi /usr/sbin/modprobe /sbin/modprobe   # shows target of the symbolic link.
1312245 -rwxr-xr-x. 1 root root 165592 Feb  8 04:34 /sbin/modprobe
1312245 -rwxr-xr-x. 1 root root 165592 Feb  8 04:34 /usr/sbin/modprobe

Also /bin is a symbolic to /usr/bin

ls -li /bin/kmod /usr/bin/kmod
1312245 -rwxr-xr-x. 1 root root 165592 Feb  8 04:34 /bin/kmod
1312245 -rwxr-xr-x. 1 root root 165592 Feb  8 04:34 /usr/bin/kmod

Thus, your new symbolic link does not change anything.

villykruse gravatar imagevillykruse ( 2018-06-27 04:46:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-03-24 12:01:15 -0500

Seen: 5,623 times

Last updated: Jun 27 '18