Ask Your Question
2

No mouse settings in System Settings

asked 2018-03-27 16:22:08 -0600

enenou gravatar image

updated 2018-03-31 07:19:46 -0600

I do have one though. Where is it and how to configure it? What I want now is to enable double-click to open files/folders as opposed to default single-click.

I'm using Fedora 27 KDE.

edit retag flag offensive close merge delete

Comments

Very good question (cannot upvote yet). The mouse settings are absent under "Input devices" category, beside Touchpad ( https://pasteboard.co/HejjK7G.png ). I wander whether this is Fedora or KDE bug. I suggest adding the KDE/Dolphin specification in the name of the question.

cip_fedora gravatar imagecip_fedora ( 2018-03-30 10:17:12 -0600 )edit

upvoted for you, good question.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-03-30 11:25:16 -0600 )edit

hello, I do have the mouse settings option there, fedora 27 spin, only update your system.

christianbueno gravatar imagechristianbueno ( 2018-03-31 23:02:45 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-03-30 10:31:57 -0600

cip_fedora gravatar image

updated 2018-03-30 11:00:19 -0600

This is a bug with Plasma 5 in Fedora before Plasma version 5.12.3 which reportedly solves the problem, as said here and here.

Plasma version 5.12.3 at this date needs the updates-testing repo to be enabled.

On how to do that (on your own risk), see here how to add the repo and update and here how to enable and disable that repo.


What I did is:

sudo dnf --enablerepo=updates-testing update 'kf5*' 'plasma*'

sudo dnf config-manager --set-disable updates-testing

Logged out and back and the mouse setting its there beside Touchpad, as expected.


But I do not recommend this.

The update from testing repos may bring more bugs than it solves.

(A bug that appeared instantly: no wallpaper for the login screen until I changed the login theme from Breeze Fedora to Breeze.)

edit flag offensive delete link more
2

answered 2018-03-31 23:22:34 -0600

christianbueno gravatar image

Only update your system.

$ sudo dnf update

image description

image description

image description

edit flag offensive delete link more

Comments

so soon? great!

cip_fedora gravatar imagecip_fedora ( 2018-04-01 16:37:40 -0600 )edit

it works now, thank you!

enenou gravatar imageenenou ( 2018-04-04 12:58:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-03-27 16:22:08 -0600

Seen: 631 times

Last updated: Mar 31 '18