How can I enable jumbo frames permanently?

asked 2018-04-18 20:39:48 -0500

hsljo gravatar image

Added MTU=9000 to the interface configuration:

[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-enp2s0 
TYPE=Ethernet
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=none
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=eth0
UUID=2b77364f-31e9-3eed-adee-8ab5442b3ed9
ONBOOT=yes
AUTOCONNECT_PRIORITY=-999
DEVICE=enp2s0
ETHTOOL_OPTS="autoneg off speed 1000 duplex full"
IPADDR=10.10.10.3
PREFIX=8
GATEWAY=10.10.10.1
DNS1=10.10.10.1
MTU=9000

Restarting network service:

[root@localhost ~]# systemctl restart network.service
Job for network.service failed because the control process exited with error code.
See "systemctl  status network.service" and "journalctl  -xe" for details.

Pings are not going through:

[root@localhost ~]# ping -v -M do -s 8972 -c2 10.10.10.2
ping: socket: Permission denied, attempting raw socket...
ping: socket: Permission denied, attempting raw socket...
PING 10.10.10.2 (10.10.10.2) 8972(9000) bytes of data.

--- 10.10.10.2 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 1049ms

According to this bug report with ping permissions should have been fixed, but it's OK as after chmodding ping as per the bug description it no longer prints the error message.

So bottom line is, how can I enable jumbo frames in 26? I am on the latest available kernel and other updates:

[root@localhost ~]# uname -a
Linux localhost.localdomain 4.15.16-200.fc26.x86_64 #1 SMP Mon Apr 9 17:49:29 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
edit retag flag offensive close merge delete