Ask Your Question
1

Set keyboard map on logon screen

asked 2018-05-06 10:34:02 -0500

Mic gravatar image

updated 2018-05-16 13:18:02 -0500

I have both fr and eng keyboard maps added in the keyboard settings. My default one is fr.

When I boot up, the logon screen shows, as expected, fr on the top right corner. But even though it shows fr, the eng keyboard map is in use when I type in my password.

This behaviour only shows up when booting up, not when logging on back from suspended.

How do I force the right keyboard layout when I boot up?

(Reproduced the same issue on my laptop)

$ uname -a

Linux michome-fedora 4.16.5-300.fc28.x8664 #1 SMP Fri Apr 27 17:38:36 UTC 2018 x8664 x8664 x8664 GNU/Linux


Edit later : This bug has been fixed in the last update.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-05-07 09:17:32 -0500

ghyde gravatar image

This is a known bug in Fedora 28. You can track the bug here and download a patched gnome-shell here.

After installing the RPM and rebooting my machine, I no longer had this issue.

dnf install https://kojipkgs.fedoraproject.org//work/tasks/2551/26772551/gnome-shell-3.28.1-4.fc28.x86_64.rpm
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-06 10:33:47 -0500

Seen: 240 times

Last updated: May 16