Ask Your Question
1

fail to sync repo 'phracek-PyCharm' disabling

asked 2018-05-14 00:37:44 -0500

updated 2018-05-31 05:33:02 -0500

FranciscoD_ gravatar image

While updating it always says fail to syncronize pycharm repo. why ?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2018-05-17 06:46:32 -0500

florian gravatar image
edit flag offensive delete link more
0

answered 2019-02-08 07:42:35 -0500

Entropy813 gravatar image

updated 2019-02-08 07:47:26 -0500

This tends to be a recurring problem for me. Personally, I think that phracek's PyCharm copr should be removed from the fedora-workstation-repositories due to the continuing issues it causes, and from the conversation here, it seems like phracek might not really want their repo to be a part of that package anyway. However, in the meantime here are some suggestions.

If, like me, you constantly get error messages as the system checks for updates automatically (I'm using KDE) which say something to the effect of: Failed to syncrhonize info for '/var/cache/PackageKit/28/metadata/phracek-PyCharm/repodata/(long string of letters and numbers).xml.gz' file or directory doesn't exist', there are two options that may work for you.

Run:

$ sudo dnf reinstall fedora-workstation-repositories

This seems to refresh all the information and the error then goes away for a while (few weeks or so) at least.

The other option, if you don't need the PyCharm repo, would be to remove the fedora-workstation-repositories package and just install the third party repos that you need manually.

edit flag offensive delete link more
0

answered 2018-05-14 15:04:59 -0500

florian gravatar image

updated 2018-05-15 01:58:26 -0500

That is a copr that you must have enabled previously -maybe this one here, or following this article?

The message just says that it is not available for syncing metadata, which can have various reasons. Are you upgrading to F28? Maybe your packages from that repo haven't been built for F28, or the server was down, or ...

What's the content of your /etc/yum.repos.d/_copr_phracek-PyCharm.repo?

edit flag offensive delete link more

Comments

yes i upgraded F28 and enable third party repo and my content in /etc/yum.repos.d/coprphracek-Pycharm is

[phracek-PyCharm]
name=Copr repo for PyCharm owned by phracek
baseurl=https://copr-be.cloud.fedoraproject.org/results/phracek/PyCharm/fedora-$releasever-$basearch/
skip_if_unavailable=True
gpgcheck=1
gpgkey=https://copr-be.cloud.fedoraproject.org/results/phracek/PyCharm/pubkey.gpg
enabled=1
enabled_metadata=1
duckfern gravatar imageduckfern ( 2018-05-15 00:50:09 -0500 )edit

That’s an issue with the repository. If you take a look at the URL in baseurl you’ll see that there is no build for F28. That looks like a bug worth reporting to the owner of the copr

florian gravatar imageflorian ( 2018-05-15 01:57:39 -0500 )edit

How can I report bug please send me a link

duckfern gravatar imageduckfern ( 2018-05-15 02:12:33 -0500 )edit

This page has contact information.

villykruse gravatar imagevillykruse ( 2018-05-15 04:14:46 -0500 )edit

I mailed to owner about this bug apart from this any other suggestion to rectify this problem.

duckfern gravatar imageduckfern ( 2018-05-16 10:48:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-14 00:37:44 -0500

Seen: 447 times

Last updated: Feb 08