Ask Your Question
4

Fedora 28 Gnome UI not responding after login.

asked 2018-05-14 18:51:28 -0600

Gion gravatar image

Before i sudo dnf updated today, it was working fine. After the update, every time i login nothing works, the only thing i could do was move the mouse pointer. The keyboard or clicking on the mouse did not work. I tried restarting 3 times and it still doesn't work.

edit retag flag offensive close merge delete

Comments

does Ctrl-Alt-F2 get you to another tty terminal, to login as root? if so then consider that your compiler may not match the previous kernel version, and if you use dkms to update video or other drivers, they may not load properly. if you do dnf downgrade gcc to the previous version, reinstall the drivers that use dkms, and then reboot, it will probably work.

steveebey73742 gravatar imagesteveebey73742 ( 2018-05-14 19:07:25 -0600 )edit

Nope keyboard is not working at all. PS: also the clock and weather is still working i just cant interact with the Desktop UI.

Gion gravatar imageGion ( 2018-05-14 19:56:36 -0600 )edit

I have the same issue. I updated from GNOME Software. I can access another TTY but only from the login screen. Once I login no input is recognized, but the mouse still works. The weather and clock still works, as do notifications. I tried GNOME Wayland, XOrg X11, and Classic and no change. I'm on a Dell XPS 9350, i5 version if that helps. I downgraded GCC as the above poster recommended but no dice. DKMS wasn't even installed.

iasoren gravatar imageiasoren ( 2018-05-14 22:11:30 -0600 )edit

I have since updated the system again and no change.

iasoren gravatar imageiasoren ( 2018-05-14 22:16:48 -0600 )edit

I can confirm that a clean install followed by an update lends the same error. Rolling the transaction back returns the system to a functional state. I'm not sure what the offending package is.

iasoren gravatar imageiasoren ( 2018-05-14 23:25:57 -0600 )edit

6 Answers

Sort by » oldest newest most voted
4

answered 2018-05-18 02:34:32 -0600

KitsuneKitty gravatar image

updated 2018-05-19 03:21:59 -0600

This happened to me as well.

I tried reloading and it still wasn't working. I also tried installing OpenSUSE Tumbleweed and ran into the exact same problem. I reloaded Fedora once I realized the problem was in my own $HOME.

The problem seems the be a rouge extension. I would clear your extensions -- specifically, the one that seems to be causing the issue is "Workspaces to Dock".

What I would do is hit ctrl+alt+f3 and then cd ~/.local/share/gnome-shell/extensions. Once in ls and then rm -rf the folder containing the "Workspaces to Dock" extension. If it still continues to clear all your extensions. If it still persists, clear all your Gnome settings but this should not be necessary if it is the same issue. Shame because it was my favorite extension. I hope there is a fix soon.

UPDATE: The newest version of the extension as it is in GitHub appears to work and does not lock up Gnome Shell.

The author of the extension said that Version 45 should be landing on the Gnome Extension website in the next few days and they have been slow to update the site because there have been a lot of submissions.

edit flag offensive delete link more

Comments

Thank's --- this fixed it for me. The problem was "Workspaces to Dock".

ldlyu gravatar imageldlyu ( 2018-05-18 11:27:31 -0600 )edit

Thank you this fixed it for me too - sorry, but it won't allow me to "upvote"!

Caoimhin_B gravatar imageCaoimhin_B ( 2018-05-18 21:26:33 -0600 )edit

UPDATE: The newest version of the extension as it is in GitHub appears to work and does not lock up Gnome Shell.

The author of the extension said that Version 45 should be landing on the Gnome Extension website in the next few days and they have been slow to update the site because there have been a lot of submissions.

KitsuneKitty gravatar imageKitsuneKitty ( 2018-05-19 03:21:16 -0600 )edit

This worked perfectly for me. Thanks!

zach gravatar imagezach ( 2018-05-26 09:59:05 -0600 )edit
2

answered 2018-05-15 07:05:44 -0600

hhlp gravatar image

updated 2018-05-15 12:22:53 -0600

The problem occurs since yesterday,

You can login and enter your password but when you login into gnome the system don't response but you can move the mouse...

I have the same problem I have to start with Live dvd and chroot my environment and downgrade all this packages :

LibRaw                         x86_64     0.18.11-1.fc28     updates     349 k
 bodhi-client                   noarch     3.7.0-1.fc28       updates      53 k
 fontconfig                     x86_64     2.13.0-4.fc28      updates     253 k
 gnome-boxes                    x86_64     3.28.4-1.fc28      updates     1.1 M
 gnome-calendar                 x86_64     3.28.2-1.fc28      updates     808 k
 gnome-characters               x86_64     3.28.2-1.fc28      updates     254 k
 gnome-contacts                 x86_64     3.28.2-1.fc28      updates     463 k
 gnome-desktop3                 x86_64     3.28.2-1.fc28      updates     563 k
 gnome-disk-utility             x86_64     3.28.2-1.fc28      updates     1.1 M
 gnome-getting-started-docs     noarch     3.28.2-1.fc28      updates      10 M
 gnome-keyring                  x86_64     3.28.2-1.fc28      updates     846 k
 gnome-keyring-pam              x86_64     3.28.2-1.fc28      updates      44 k
 gnome-logs                     x86_64     3.28.2-1.fc28      updates     482 k
 gnome-maps                     x86_64     3.28.2-1.fc28      updates     721 k
 gnome-shell                    x86_64     3.28.2-1.fc28      updates     2.1 M
 gnome-software                 x86_64     3.28.2-1.fc28      updates     3.8 M
 gnome-system-monitor           x86_64     3.28.2-1.fc28      updates     760 k
 gvfs                           x86_64     1.36.2-1.fc28      updates     344 k
 gvfs-afc                       x86_64     1.36.2-1.fc28      updates      83 k
 gvfs-afp                       x86_64     1.36.2-1.fc28      updates      94 k
 gvfs-archive                   x86_64     1.36.2-1.fc28      updates      51 k
 gvfs-client                    x86_64     1.36.2-1.fc28      updates     797 k
 gvfs-fuse                      x86_64     1.36.2-1.fc28      updates      55 k
 gvfs-goa                       x86_64     1.36.2-1.fc28      updates      86 k
 gvfs-gphoto2                   x86_64     1.36.2-1.fc28      updates      86 k
 gvfs-mtp                       x86_64     1.36.2-1.fc28      updates      86 k
 gvfs-smb                       x86_64     1.36.2-1.fc28      updates      68 k
 python2-bodhi                  noarch     3.7.0-1.fc28       updates      24 k
 wpa_supplicant                 x86_64     1:2.6-15.fc28      updates     1.6 M

Howto chroot: in a LVM environment default fedora instalation :

sudo lsblk

NAME            MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda               8:0    0 149,1G  0 disk 
├─sda1            8:1    0     1G  0 part /boot
└─sda2            8:2    0   148G  0 part 
  ├─fedora-root 253:0    0  93,1G  0 lvm  /
  ├─fedora-swap 253:1    0   3,7G  0 lvm  [SWAP]
  └─fedora-home 253:2    0  51,2G  0 lvm  /home
sdb               8:16   0 931,5G  0 disk 
└─sdb1            8:17   0 931,5G  0 part 
sdc               8:32   0 186,3G  0 disk 
└─sdc1            8:33   0 186,3G  0 part 
sr0              11:0    1  1024M  0 rom

then :

su - 
mount /dev/fedora /root ./
mount /dev/fedora/home home/
mount -t proc proc proc/
mount --rbind /sys sys/
mount --rbind /dev dev/
mount --rbind /var/run var/run/
chroot /mnt

and then you can downgrade your packages or use the follow dnf command :

dnf history - here you obtain your command `number` and all the info
dnf history info #number#
dnf history undo #number#

Regards.,

edit flag offensive delete link more

Comments

1

As I mentioned earlier, I can log in as either ROOT or use a different window env (I'm using budgie).

I used the "Software Center" update mechanism and this DOESN'T seem to create a dnf history entry.

LESSON LEARNED: NEVER USE SOFTWARE STORE TO UPDATE THE OS.

I'm fortunate that Budgie is working fine and I prefer it, but this issue needs to get fixed by the Gnome maintainers as I am sure MANY people have this issue.

TheBigDuck gravatar imageTheBigDuck ( 2018-05-15 09:37:05 -0600 )edit

Sorry gonna need more instructions on the mount part cause i have two drives with fedora, one mate(sda) which is working and the other gnome(sdb) which is the problem. I want to make sure I mount the right one.

Gion gravatar imageGion ( 2018-05-15 15:49:37 -0600 )edit

Gion, assuming you used dnf you can get to the login screen, switch to a different TTY, and then roll back the dnf update. In your case that is probably easier than chrooting in.

iasoren gravatar imageiasoren ( 2018-05-16 14:31:41 -0600 )edit
1

answered 2018-05-15 13:20:35 -0600

I have the same problem with my Dell Optiplex 755. I booted to level 3 and disabled Wayland in /etc/gdm/custom.conf, then rebooted and got the XServer login manager.

edit flag offensive delete link more
0

answered 2018-05-15 02:55:37 -0600

AgentQ gravatar image

updated 2018-05-15 20:05:23 -0600

This is not a definite permanent solution so try the following: - At grub menu, edit the boot with e and add nomodeset after quiet and hit CTRL+x to start the boot.

If you managed to login and able to interact with everything, then its a problem with GNOME DE with whatever video driver you have.

To install any of the drivers is something I havn't figured out yet. But if you want to set this current nomodeset as permanent with the low resolution and low graphic setting, do grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg for UEFI users. There's another that's for BIOS users to grub2-mkconfig but unable to find it.

edit flag offensive delete link more
0

answered 2018-05-15 00:41:25 -0600

wyvis73 gravatar image

I have the same issues reported when I upgraded my Dell Optiplex 755 GNOME Software from Fedora 27 to Fedora 28 on 5/1/2018. I followed the sudo dnf system-upgrade procedure to upgrade my Workstation. Upon reboot, the computer loads up to just before the user login screen and freezes. At this point nothing responds. I have rebooted several times and cannot even use The Live Image to install Fedora 28.

When I DOWNGRADE to try to use Fedora 27, still the system still freezes. Any ideas on boot workarounds to resolve this issue?

edit flag offensive delete link more

Comments

You might be able to solve this with:

dnf history - here you obtain your command `number` and all the info
dnf history info #number#
dnf history undo #number#

Since you were smart enough to use dnf to update.

TheBigDuck gravatar imageTheBigDuck ( 2018-05-15 10:20:17 -0600 )edit
0

answered 2018-05-16 09:41:37 -0600

Caoimhin_B gravatar image

Got the same problem on a home built system and a 2015 MacBook pro.

Occasionally after a bounce using journalctl -p err -b I will see that gnome-shell cored, but researching that hasn't been particularly fruitful - especially as I see the same problem if I boot into gnome classic or gnome xorg.

I've also tried with wayland enabled/disabled to no avail.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2018-05-14 18:51:28 -0600

Seen: 2,877 times

Last updated: May 19