Ask Your Question
2

fedora 28 - gnome default keyring not opened on login

asked 2018-05-15 10:01:07 -0500

tigerpaws gravatar image

Since gnome 3.28 has finally gotten support for ed25519 keys, I decided to properly use the gnome keyring. I added the following to my .bash_profile:

export $(gnome-keyring-daemon)

to set the SSHAUTHSOCK variable. This works fine in gterm sessions, but I now get

the login keyring did not get unlocked when you logged in to your computer

everytime I login. The login password for my account is the same as the keyring password. This is not autologin, I type my password everytime I login. I was under the impression that if the password was the same, the keyring would be automatically unlocked.

There is only the login keyring, I even went into the "password and keys" app and changed the password (to make sure it was the same as the login password), to no avail.

How can I get the keyring automatically unlocked by my login? I run gnome under wayland.

Thanks,

Mike

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2018-08-28 19:34:01 -0500

seanf gravatar image

Try this:

Enable "Certificate and Key Storage (GNOME Keyring: PKCS#11 Component)", "Secret Storage Service (GNOME Keyring: Secret Service)" and "SSH Key Agent (GNOME Keyring: SSH Agent)" in Session and Startup (Application Autostart).

(Thanks to PabloTwo: https://forums.fedoraforum.org/showth... )

edit flag offensive delete link more
0

answered 2018-05-16 08:16:52 -0500

villykruse gravatar image

You can unlock gnome-keyring at log-in time, but that requires an additional pam module gnome-keyring-pam. Only the pam module as access to your login password.

I would expect that the gnome environment will do everything needed to make this work automatically.

Do remove the line export $(gnome-keyring-daemon) from .bash_profile.

edit flag offensive delete link more
0

answered 2018-05-16 06:42:55 -0500

rhandwor52 gravatar image

I have the same problem it's something that skype added so you are logged into skype. I open clamtk and the message to log into key ring appears.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-05-15 10:01:07 -0500

Seen: 657 times

Last updated: May 16