Ask Your Question
0

Stuck at 800x600 Resolution, Nouveau and NVIDIA Driver Failed in Dual Boot

asked 2018-05-15 21:13:28 -0500

AgentQ gravatar image

updated 2018-05-16 04:31:44 -0500

Freshly installed Fedora 27 in Dual Boot via disabled Secure Boot in UEFI with Windows 10. The first problem I had was during the installation from a Live USB where I selected either "Start Fedora..." or "Test Media & Start Fedora...". Neither could get me past the login screen where the whole thing freezes and unable to execute any command let alone switch via CTRL+ALT+F2~F4. The third option "Troubleshooting" got me past the login screen and help me with the install but at the lowest possible resolution (800x600). My initial thought was probably a display driver issue or incompatibility.

I begin by checking my drivers:

[root@localhost ~]# lspci | grep -E "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02) 
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)

So I tried installing NVIDIA drivers following from If-Not-True-Then-False. According to the guide, I am to download the driver 390.48 since my kernel is: 4.16.7-200.fc27.x86_64. It was a fail and I ended up with an error for Unable to load 'nvidia-drm' kernel module. My secure boot was already disabled so I tried signing the driver myself but it was so complicated that I don't understand how to do it.

I tried another solution with RPMFusion and that failed by not booting up properly. Although after reversing and undoing the nvidia install, I now have the following:

My Xorg Logs

https://paste.fedoraproject.org/paste...

https://paste.fedoraproject.org/paste...

I am fine with not using NVIDIA drivers at all at this point, I just want a higher resolution to do my work on.

My xrandr shows:

[root@localhost Downloads]# xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 800 x 600, maximum 800 x 600
default connected primary 800x600+0+0 0mm x 0mm
   800x600       75.00*

Currently my grub is:

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet selinux=0 nomodeset"
GRUB_DISABLE_RECOVERY="true"
GRUB_GFXMODE="auto"

I had to set nomodeset because of some problem with nouveau? Something about nouveau. func 08 lookup failed, -2.

[root@localhost Downloads]# lsmod | grep nouveau
nouveau              2007040  0
mxm_wmi                16384  1 nouveau
ttm                   126976  1 nouveau
i2c_algo_bit           16384  2 nouveau,i915
drm_kms_helper        196608  2 nouveau,i915
drm                   454656  4 nouveau,i915,ttm,drm_kms_helper
wmi                    28672  3 msi_wmi,mxm_wmi,nouveau
video                  45056  3 msi_wmi,nouveau,i915

So I am able to use Fedora but now stuck at 800x600 resolution. What do I do?

Update: added dmesg logs of nouveau fail

https://paste.fedoraproject.org/paste...

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-05-15 22:50:34 -0500

nilz3ro gravatar image

AgentQ,

Have you tried adding nouveau.modeset=0 to the end of the linux16 line in the kernel params before you boot? That should get you around the nouveau drivers until you can install something like bumblebee.

This method worked for me. I'm running Fedora 28 on a Dell XPS-15 9560 laptop with an "Optimus" enabled Nvidia card. Nouveau isn't very reliable on newish laptops with discrete Nvidia cards yet.

edit flag offensive delete link more

Comments

Installed bumblebee.

After it booted up, I still have that nouveau disp: conn func 07 lookup failed, -2 and so on.

Then all of the resources load until it stopped at Started GNOME Display Manager....idia did not load....es.S....150-861c-ba1b031a788f......

Well that gave me a little hope but haven’t even gotten to the login screen yet.

AgentQ gravatar imageAgentQ ( 2018-05-16 04:26:15 -0500 )edit
0

answered 2018-05-24 05:14:31 -0500

AgentQ gravatar image

I finally got it to work. I reversed every installation from every guide that I followed from rpmfusion, negativo17, bumblebee, and if-not-true-then-false, since none of those works. I also removed the repo as well and did another dnf update

After that, I searched for any official nvidia package in the official repo and found xorg-x11-drv-nouveau-1.0.15-3.fc27.x86_64. Ran dnf install xorg-x11-drv-nouveau-1.0.15-3.fc27.x86_64, reboot, and it suddenly works.

My grub: GRUB_TIMEOUT=5 GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)" GRUB_DEFAULT=saved GRUB_DISABLE_SUBMENU=true GRUB_TERMINAL_OUTPUT="console" GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet selinux=0 nouveau.modeset=0" GRUB_DISABLE_RECOVERY="true" GRUB_GFXMODE="auto"

My xrandr -q: Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192 eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm 1920x1080 60.01*+ 60.01 59.97 59.96 59.93 1680x1050 59.95 59.88 1400x1050 59.98 1600x900 59.99 59.94 59.95 59.82 1280x1024 60.02 1400x900 59.96 59.88 1280x960 60.00 1440x810 60.00 59.97 1368x768 59.88 59.85 1280x800 59.99 59.97 59.81 59.91 1280x720 60.00 59.99 59.86 59.74 1024x768 60.04 60.00 960x720 60.00 928x696 60.05 896x672 60.01 1024x576 59.95 59.96 59.90 59.82 960x600 59.93 60.00 960x540 59.96 59.99 59.63 59.82 800x600 60.00 60.32 56.25 840x525 60.01 59.88 864x486 59.92 59.57 700x525 59.98 800x450 59.95 59.82 640x512 60.02 700x450 59.96 59.88 640x480 60.00 59.94 720x405 59.51 58.99 684x384 59.88 59.85 640x400 59.88 59.98 640x360 59.86 59.83 59.84 59.32 512x384 60.00 512x288 60.00 59.92 480x270 59.63 59.82 400x300 60.32 56.34 432x243 59.92 59.57 320x240 60.05 360x202 59.51 59.13 320x180 59.84 59.32 HDMI-1 disconnected (normal left inverted right x axis y axis) DP-1 disconnected (normal left inverted right x axis y axis) HDMI-2 disconnected (normal left inverted right x axis y axis)

Also I switched from gdm to lightdm:

Redirecting to /bin/systemctl status lightdm.service ● lightdm.service - Light Display Manager Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled) Active: active (running) since Thu 2018-05-24 05:51:19 EDT; 19min ago Docs: man:lightdm(1) Main PID: 881 (lightdm) Tasks: 9 (limit: 4915) CGroup: /system.slice/lightdm.service ├─ 881 /usr/sbin/lightdm ├─ 902 /usr/libexec/Xorg -core -noreset :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt1 -novtswitch -background none └─1169 /usr/bin/gnome-keyring-daemon --daemonize --login

Redirecting to /bin/systemctl status gdm.service ● gdm.service - GNOME Display Manager Loaded: loaded (/usr/lib/systemd/system/gdm.service; disabled; vendor preset: disabled) Active: inactive (dead)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-05-15 21:13:28 -0500

Seen: 213 times

Last updated: May 24