Ask Your Question
2

Troubleshooting display manager installation on Fedora Server minimal

asked 2018-05-23 02:28:17 -0500

faokryn gravatar image

Summary:

I am attempting to install a display manager, preferably lxdm, on Fedora 28 Server. Simply installing via dnf did not work, and troubleshooting steps I've found online so far have not provided a solution.

Background:

I've been working on building a workstation environment starting from a Fedora 28 Server Edition minimal "custom operating system" install. Until recently, I was logging in at the tty login and using $ startx with exec awesome in my ~/.xinitrc to get a desktop environment. I wanted to give i3 a try, so I thought it would be the perfect time to install a graphical display manager to make switching between window managers easier. I installed lxdm using $ sudo dnf install lxdm, but on reboot I still end up at the tty login.

Troubleshooting Steps:

I verified the installation with $ which lxdm which returned /usr/sbin/lxdm. Running $ sudo lxdm hangs for a bit, but does nothing visible.

Following the troubleshooting advice here, I checked that lxdm.service was enabled with $ sudo systemctl status lxdm.service | grep enabled which returned Loaded: loaded (/usr/lib/systemd/system/lxdm.service; enabled; vendor preset: enabled). Even though the service appeared to be enabled, I ran $ sudo systemctl enable lxdm for good measure. I confirmed that on reboot the tty login still appeared. I manually started the service (from within an X11 session) using $ sudo systemctl start lxdm, and this did start lxdm successfully.

Following the troubleshooting advice here, I added an /etc/sysconfig/desktop (one did not exist by default) using $ sudo sh -c 'echo "DISPLAYMANAGER=/usr/sbin/lxdm" > /etc/sysconfig/desktop'. I confirmed that on reboot the tty login still appeared. I removed /etc/sysconfig/desktop after this troubleshooting step didn't work.

Following the troubleshooting advice here, I verified that the link exists, using $ ls -l /etc/systemd/system/display-manager.service, which returned lrwxrwxrwx. 1 root root 36 May 23 00:37 /etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/lxdm.service.

Finally, I uninstalled lxdm and installed lightdm using $ sudo dnf remove lxdm && sudo dnf install lightdm && sudo systemctl enable lightdm.service to verify that it is not a problem specifically with lxdm. Upon reboot, I verified that I still ended up at the tty login.

This has me pretty stumped. Any troubleshooting advice I could get would be very appreciated.

edit retag flag offensive close merge delete

Comments

1
hhlp gravatar imagehhlp ( 2018-05-23 10:10:15 -0500 )edit

Thanks @hhlp, but installing an entire desktop environment would be contrary to my intentions. I'm specifically trying to build up from a minimal install.

faokryn gravatar imagefaokryn ( 2018-05-23 12:33:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-05-24 09:41:25 -0500

villykruse gravatar image

Did you also run systemctl set-default graphical.target?

edit flag offensive delete link more

Comments

@villykruse That seems to have done the trick! Thank you!

faokryn gravatar imagefaokryn ( 2018-05-24 15:10:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-23 02:28:17 -0500

Seen: 399 times

Last updated: May 23 '18