F28 Server Installation in FIPS mode failing

asked 2018-06-01 18:19:16 -0500

drkwood gravatar image

I am trying to get some insight into the next RHEL, and have just attempted to install the latest Fedora Server 28 (Fedora-Server-dvd-x86_64-28-1.1.iso). I typically install RHEL by using the grub directive "fips=1" to ensure all crypto processes during Anaconda operate with a FIPS-level algorithm and the resulting installation will successfully boot in FIPS mode.

However, the current version appears to be failing to boot at the "Apply Kernel Variables" step, and then enters an infinite loop trying to start the Journal Service. I have previously not needed to debug the installation CD, and am unsure where to go from here.

I have validated this behavior on a physical machine (UEFI) and a virtual machine (VMware Workstation, both BIOS & UEFI).

Thanks in advance

EDIT: This appears to also affect F27 (Fedora-Server-dvd-x8664-27-1.6.iso), but F26 (Fedora-Server-dvd-x8664-26-1.5.iso) booted into Anaconda OK.

edit retag flag offensive close merge delete

Comments

Seem like there is an issue with kernel 4.16.4 look here it may cause the issue you are experience

aeperezt gravatar imageaeperezt ( 2018-06-01 19:39:04 -0500 )edit