Clover, multiboot and multiple efi partitions - Can't add all OSes to Clover

asked 2018-06-04 00:18:39 -0500

syntha gravatar image

Hello!

i have 2 HDDs in my system, one for windows and one for multiple OSes.

Partitioning:

sda

  • sda1->System Reserved
  • sda2->Main Windows Drive (it also contains the efi folder, this disk doesn't have actual efi folder)
  • sda3, sda4 -> some NTFS Non-bootable volumes (mainly for storage etc)

sdb: (new hard drive, this drive is gonna be my OS testing bentch)

  • sdb1 -> EFI partition (created way after windows, contains Clover and Fedora's efi bootloader)
  • sdb2 -> swap partition
  • sdb3 -> Main Fedora Drive

i don't have any other OS installed atm so the partitioning stops there

So, what's the problem?

When i try to boot from clover, i only see Windows. I tried manualy adding the Fedora entry (i used both "EFI" and sdb1's PARTUUID) and none of them did worked.

What i actually try to do is to leave untouched the sda and make Clover see the entries inside its own EFI directory (or at least add them manually in a way that it can see them)

My Setup:

Asus Z170-A

i5 6600k

8gb ddr4 Ram

MSI GTX650 gpu

2x 7200RPM HDDs

Do you have any suggestions?

Thank you in Advance!

edit retag flag offensive close merge delete

Comments

I use clover but I can't tell you how it enumerates things on the ESP, for all I know it only enumerates based on NVRAM entries, or otherwise ignores things on the ESP it doesn't recognize. I think the question is better asked in a clover specific forum or github issue, as it's an extremely non-Fedora specific question.

cmurf gravatar imagecmurf ( 2018-06-07 13:40:28 -0500 )edit