Ask Your Question
1

mem_sleep_default ignored; adding initrd images permanently

asked 2018-06-12 02:19:07 -0500

b0wter gravatar image

I'm using Fedora 28 Workstation Edition on an X1 Carbon which only offers SOi3. There is a guide (https://delta-xi.net/#056) that gives instructions on how to retrieve and patch the ACPI table to make it use S3. I've done the following:

  • created a new CPIO Image named: /boot/acpi_override (according to the instructions above)
  • added mem_sleep_default=deep to GRUB_CMDLINE_LINUX in /etc/default/grub and ran grub2-mkconfig -o /boot/grub2/grub.cfg
  • when booting I pressed e to enter the grub configuration tool and added /acpi_override to the initrd line (before the kernel image)

However, /sys/power/mem_sleep still shows brackets around s2idle despite deep being an option. (which I obviously dont want to use). I can change that by using echo deep > /sys/power/mem_sleep as root which makes it persist as long as I dont reboot. The laptop will then enter the desired standby mode if I close the lid of chose suspend from the power menu. I also need to add the /acpi_override each time I boot which gets annoying easily.

So my two questions are:

  • Why is mem_sleep_default=deep "ignored"? And what is the best way to set it manually?
  • How can I permanently add the /acpi_override image?
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-06-12 06:05:30 -0500

hhlp gravatar image

updated 2018-06-12 06:18:00 -0500

@b0wter , please read this -> X1-Carbon-Gen-6-cannot-enter-deep-sleep-S3-state-aka-Suspend-to check if your are in UEFI that is diferent that GRUB more info -> GRUB_2 the command for UEFI is grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

edit flag offensive delete link more

Comments

1

@hhlp Thanks for the EFI hint. Got it working that way! I've read the forum thread already. Found it, together with the delta-xi guide in the Arch Linux Wiki. The remaining thing for me is how to automatically add /acpi_override to the initrdefi line when using grub2-mkconfig.

b0wter gravatar imageb0wter ( 2018-06-12 15:14:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-06-12 02:19:07 -0500

Seen: 17 times

Last updated: Jun 12